<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8" />
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <meta name="google-site-verification" content="cn5-gurGUvjtlzniBhOIPjfKHzuAplh_R9Ju9tuL0DM" />

  <!-- Twitter and Facebook OpenGraph Metadata-->
  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@code" />

  <meta itemprop="applicationCategory" content="Text Editor">
  <meta itemprop="datePublished" content="2016-04-14">
  <meta itemprop="operatingSystem" content="Mac, Linux, Windows" />

  	<meta name="keywords" content="vscode API" />
	
	<meta name="description" content="Learn how to create Language Servers to provide rich language features in Visual Studio Code." />
	
    <meta name="ms.prod" content="vs-code" />
	<meta name="ms.TOCTitle" content="Language Server Extension Guide" />
	<meta name="ms.ContentId" content="A8CBE8D6-1FEE-47BF-B81E-D79FA0DB5D03" />
	<meta name="ms.topic" content="conceptual" />
	<meta name="ms.date" content="5/7/2020" />
	<!-- Twitter and Facebook OpenGraph Metadata-->
    <meta name="twitter:card" content="summary_large_image" />
	<meta property="og:url" content="https://code.visualstudio.com/api/language-extensions/language-server-extension-guide"/>
	
	<meta property="og:description" content="Learn how to create Language Servers to provide rich language features in Visual Studio Code."/>
	
    <meta property="og:type" content="article"/>
    <meta property="og:title" content="Language Server Extension Guide"/>
    <meta property="og:image" content="https://code.visualstudio.com/opengraphimg/opengraph-docs.png"/>


  <link rel="shortcut icon" href="/favicon.ico" sizes="128x128" />
  <link rel="apple-touch-icon" href="/apple-touch-icon.png">

  <title>Language Server Extension Guide | Visual Studio Code Extension API</title>

  <link rel="stylesheet" href="/vendor/bootstrap/css/bootstrap.min.css">
  <!-- EU Cookie Compliance CSS -->
  <link rel="stylesheet" href="//uhf.microsoft.com/mscc/statics/mscc-0.3.6.min.css">
  <link rel="stylesheet" href="/dist/style.css">

  <!--Google Analytics-->
  <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  </script>
  <!-- End Google Analytics -->
  
  <!-- Global site tag (gtag.js) - Google AdWords: 881159895 -->
  <script async src="https://www.googletagmanager.com/gtag/js?id=AW-881159895"></script>
  <script>
  function loadGA () {
    window.dataLayer = window.dataLayer || [];
    function gtag(){dataLayer.push(arguments);}
    gtag('js', new Date());
    gtag('config', 'AW-881159895');
    window.gtag = gtag;
  }
  
  if (document.cookie.indexOf('MSCC=') !== -1) {
    loadGA();
  } else {
    if (mscc && mscc.on) {
      mscc.on('consent', function () {
        loadGA();
      })
    }
  }
  </script>
  <script src="https://az725175.vo.msecnd.net/scripts/jsll-4.js" type="text/javascript"></script>
  
  <link rel="alternate" type="application/atom+xml" title="RSS Feed for code.visualstudio.com" href="/feed.xml" />
</head>

<body>
  <!-- EU Cookie Compliance JS -->
  <script src="//uhf.microsoft.com/mscc/statics/mscc-0.3.6.min.js"></script>

  <div id='mscc-cookie-container'>
    <div id='msccBanner' dir='ltr' data-site-name='uhf-vscode' data-mscc-version='0.3.4' data-nver='aspnet-2.0.5' data-sver='0.1.2' class='cc-banner' role='alert'>
      <div class='cc-container'>
        <svg class='cc-icon cc-v-center' x='0px' y='0px' viewBox='0 0 44 44' height='30px' fill='none' stroke='currentColor'>
          <circle cx='22' cy='22' r='20' stroke-width='2'></circle>
          <line x1='22' x2='22' y1='18' y2='33' stroke-width='3'></line>
          <line x1='22' x2='22' y1='12' y2='15' stroke-width='3'></line>
          </svg>
            <span class='cc-v-center cc-text'>This site uses cookies for analytics, personalized content and ads. By continuing to browse this site, you agree to this use.</span>
            <a
              href='https://go.microsoft.com/fwlink/?linkid=845480'
              aria-label='Learn more about Microsoft’s Cookie Policy'
              id='msccLearnMore'
              data-mscc-ic="false"
              class='cc-link cc-v-center cc-float-right'
            >Learn more</a>
      </div>
    </div>
  </div>
  <div id="main" itemscope itemtype="http://schema.org/SoftwareApplication">
          <a role="button" id="skip-to-content" class="link-button" href="#main-content">Skip to content<i>&nbsp;</i><span class="glyphicon glyphicon-menu-down"></span></a>
          <div class="navbar-fixed-container">
              <div class="navbar navbar-inverse navbar-fixed-top ">
                  <nav role="navigation" aria-label="Top Level">
                      <div class="container">
                          <div class="nav navbar-header">
                              <a class="navbar-brand" href="/"><span itemprop="name">Visual Studio Code</span></a>
                              <button type="button" class="navbar-toggle" role="navigation" data-toggle="collapse" data-target=".navbar-collapse" aria-label="Toggle Navigation Menu">
                                  <span class="icon-bar"></span>
                                  <span class="icon-bar"></span>
                                  <span class="icon-bar"></span>
                              </button>
                          </div>
                          <div class="navbar-collapse collapse" role="navigation">
                              <ul class="nav navbar-nav navbar-left">
                                  <li ><a id="nav-docs" href="/docs">Docs</a></li>
                                  <li ><a id="nav-updates" href="/updates">Updates</a></li>
                                  <li ><a id="nav-blogs" href="/blogs">Blog</a></li>
                                  <li class="active" ><a id="nav-extend" href="/api">API</a></li>
                                  <li><a href="https://marketplace.visualstudio.com/VSCode" target="_blank" id="nav-extensions">Extensions</a></li>
                                  <li ><a id="nav-faqs" href="/docs/supporting/faq">FAQ</a></li>
                                  <li class='search visible-xs'
                                      ><a href="/Search">Search</a></li>
                              </ul>
          
                              <ul class="nav navbar-nav navbar-right">
                                  <!-- Floating search icon -->
                                  <li>
                                      <a href="/Search" title="Search" class="btn search-btn" id="nav-search">
                                          <img class="search-icon" src="/assets/icons/search.svg" width="16px" height="16px" alt="Search"/>
                                          <img class="search-icon-inverted" src="/assets/icons/search_dark.svg" width="16px" height="16px" alt="Search" />
                                      </a>
                                  </li>
                                  <!-- Actual search icon -->
                                  <li class="search">
                                      <form class="nav-search search-form" aria-label="Search"> 
                                          <div class="input-group">
                                              <input type="text" name="q" class="search-box form-control" placeholder="Search Docs" aria-label="Search text"/>
                                              <span class="input-group-btn">
                                                  <button tabindex="0" class="btn" type="submit" aria-label="Search">
                                                          <img class="search-icon" src="/assets/icons/search.svg" width="16px" height="16px" alt="Search" />
                                                          <img class="search-icon-inverted" src="/assets/icons/search_dark.svg" width="16px" height="16px" alt="Search" />
                                                  </button>
                                              </span>
                                          </div>
                                      </form>                        </li>
                                  <!-- this was hiden in the home and download page, keeping it for now -->
                                  <li><a itemprop="downloadUrl" class="link-button" href="/Download" id="nav-download">
                                      <img class="download-icon" src="/assets/icons/download.svg" width="16px" height="16px" alt="Download VS Code"/>
                                      <img class="download-icon-inverted" src="/assets/icons/download-black.svg" width="16px" height="16px" alt="Download VS Code" />
                                      <span class="hidden-sm">Download</span>
                                  </a></li>
                              </ul>
                          </div>
                      </div>
                  </nav>
              </div>
          </div>          <div class="updates-banner  ">
              <div class="container">
                  <p class="message"><a href="/updates" id="banner-link-updates">Version <span itemprop="softwareVersion">1.45</span></a> is now available! Read about the new features and fixes from April.</p>
              </div>
              <div tabindex="0" role="button" title="Dismiss this update" class="dismiss-btn" id="banner-dismiss-btn"><span class="sr-only">Dismiss this update</span><span aria-hidden="true" class="glyph-icon"></span></div>
          </div>      <div role="main" id="main-content">
        <div class="container body-content docs">
    <div class="row">
        <div class="col-md-2 docs-navbar-container">
            <nav id="docs-navbar" class="docs-nav visible-md visible-lg">
              <ul class="nav" id="main-nav">
              <li >
                <a class="docs-home" href="/api" >Overview</a>
              </li>
              
            <li class="panel collapsed">
              <a class="area" aria-label="Get Started drop down" href="#get-started-articles" data-parent="#main-nav" data-toggle="collapse">Get Started</a>
              <ul id="get-started-articles" class="collapse ">
            
                <li >
                  <a href="/api/get-started/your-first-extension" >Your First Extension</a>
                </li>
                  
                <li >
                  <a href="/api/get-started/extension-anatomy" >Extension Anatomy</a>
                </li>
                  
                <li >
                  <a href="/api/get-started/wrapping-up" >Wrapping Up</a>
                </li>
                  
              </ul>
            </li>
                
            <li class="panel collapsed">
              <a class="area" aria-label="Working With Extensions drop down" href="#working-with-extensions-articles" data-parent="#main-nav" data-toggle="collapse">Working With Extensions</a>
              <ul id="working-with-extensions-articles" class="collapse ">
            
                <li >
                  <a href="/api/working-with-extensions/testing-extension" >Testing Extensions</a>
                </li>
                  
                <li >
                  <a href="/api/working-with-extensions/publishing-extension" >Publishing Extensions</a>
                </li>
                  
                <li >
                  <a href="/api/working-with-extensions/bundling-extension" >Bundling Extensions</a>
                </li>
                  
                <li >
                  <a href="/api/working-with-extensions/continuous-integration" >Continuous Integration</a>
                </li>
                  
              </ul>
            </li>
                
            <li class="panel collapsed">
              <a class="area" aria-label="Extension Capabilities drop down" href="#extension-capabilities-articles" data-parent="#main-nav" data-toggle="collapse">Extension Capabilities</a>
              <ul id="extension-capabilities-articles" class="collapse ">
            
                <li >
                  <a href="/api/extension-capabilities/overview" >Overview</a>
                </li>
                  
                <li >
                  <a href="/api/extension-capabilities/common-capabilities" >Common Capabilities</a>
                </li>
                  
                <li >
                  <a href="/api/extension-capabilities/theming" >Theming</a>
                </li>
                  
                <li >
                  <a href="/api/extension-capabilities/extending-workbench" >Extending Workbench</a>
                </li>
                  
              </ul>
            </li>
                
            <li class="panel collapsed">
              <a class="area" aria-label="Extension Guides drop down" href="#extension-guides-articles" data-parent="#main-nav" data-toggle="collapse">Extension Guides</a>
              <ul id="extension-guides-articles" class="collapse ">
            
                <li >
                  <a href="/api/extension-guides/overview" >Overview</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/command" >Command</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/color-theme" >Color Theme</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/file-icon-theme" >File Icon Theme</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/product-icon-theme" >Product Icon Theme</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/tree-view" >Tree View</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/webview" >Webview</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/custom-editors" >Custom Editors</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/virtual-documents" >Virtual Documents</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/task-provider" >Task Provider</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/scm-provider" >Source Control</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/debugger-extension" >Debugger Extension</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/markdown-extension" >Markdown Extension</a>
                </li>
                  
                <li >
                  <a href="/api/extension-guides/custom-data-extension" >Custom Data Extension</a>
                </li>
                  
              </ul>
            </li>
                
            <li class="panel active expanded">
              <a class="area" aria-label="Language Extensions drop down" href="#language-extensions-articles" data-parent="#main-nav" data-toggle="collapse">Language Extensions</a>
              <ul id="language-extensions-articles" class="collapse in">
            
                <li >
                  <a href="/api/language-extensions/overview" >Overview</a>
                </li>
                  
                <li >
                  <a href="/api/language-extensions/syntax-highlight-guide" >Syntax Highlight Guide</a>
                </li>
                  
                <li >
                  <a href="/api/language-extensions/semantic-highlight-guide" >Semantic Highlight Guide</a>
                </li>
                  
                <li >
                  <a href="/api/language-extensions/snippet-guide" >Snippet Guide</a>
                </li>
                  
                <li >
                  <a href="/api/language-extensions/language-configuration-guide" >Language Configuration Guide</a>
                </li>
                  
                <li >
                  <a href="/api/language-extensions/programmatic-language-features" >Programmatic Language Features</a>
                </li>
                  
                <li class="active">
                  <a href="/api/language-extensions/language-server-extension-guide" aria-label="Current Page: Language Server Extension Guide">Language Server Extension Guide</a>
                </li>
                  
                <li >
                  <a href="/api/language-extensions/embedded-languages" >Embedded Languages</a>
                </li>
                  
              </ul>
            </li>
                
            <li class="panel collapsed">
              <a class="area" aria-label="Advanced Topics drop down" href="#advanced-topics-articles" data-parent="#main-nav" data-toggle="collapse">Advanced Topics</a>
              <ul id="advanced-topics-articles" class="collapse ">
            
                <li >
                  <a href="/api/advanced-topics/extension-host" >Extension Host</a>
                </li>
                  
                <li >
                  <a href="/api/advanced-topics/remote-extensions" >Remote Development and Codespaces</a>
                </li>
                  
                <li >
                  <a href="/api/advanced-topics/using-proposed-api" >Using Proposed API</a>
                </li>
                  
                <li >
                  <a href="/api/advanced-topics/tslint-eslint-migration" >Migrate from TSLint to ESLint</a>
                </li>
                  
              </ul>
            </li>
                
            <li class="panel collapsed">
              <a class="area" aria-label="References drop down" href="#references-articles" data-parent="#main-nav" data-toggle="collapse">References</a>
              <ul id="references-articles" class="collapse ">
            
                <li >
                  <a href="/api/references/vscode-api" >VS Code API </a>
                </li>
                  
                <li >
                  <a href="/api/references/contribution-points" >Contribution Points</a>
                </li>
                  
                <li >
                  <a href="/api/references/activation-events" >Activation Events</a>
                </li>
                  
                <li >
                  <a href="/api/references/extension-manifest" >Extension Manifest</a>
                </li>
                  
                <li >
                  <a href="/api/references/commands" >Commands</a>
                </li>
                  
                <li >
                  <a href="/api/references/theme-color" >Theme Color</a>
                </li>
                  
                <li >
                  <a href="/api/references/icons-in-labels" >Product Icon Reference</a>
                </li>
                  
                <li >
                  <a href="/api/references/document-selector" >Document Selector</a>
                </li>
                  
              </ul>
            </li>
                
              </ul>
            </nav>
            
            <nav id="small-nav" aria-label="Topics" class="docs-nav hidden-md hidden-lg">
            	<h4>Topics</h4>
            	<select id="small-nav-dropdown">
                <option value="/api" >Overview</option>
            
              <optgroup label="Get Started">
            
                <option value="/api/get-started/your-first-extension" >Your First Extension</option>
                
                <option value="/api/get-started/extension-anatomy" >Extension Anatomy</option>
                
                <option value="/api/get-started/wrapping-up" >Wrapping Up</option>
                
              </optgroup>
              
              <optgroup label="Working With Extensions">
            
                <option value="/api/working-with-extensions/testing-extension" >Testing Extensions</option>
                
                <option value="/api/working-with-extensions/publishing-extension" >Publishing Extensions</option>
                
                <option value="/api/working-with-extensions/bundling-extension" >Bundling Extensions</option>
                
                <option value="/api/working-with-extensions/continuous-integration" >Continuous Integration</option>
                
              </optgroup>
              
              <optgroup label="Extension Capabilities">
            
                <option value="/api/extension-capabilities/overview" >Overview</option>
                
                <option value="/api/extension-capabilities/common-capabilities" >Common Capabilities</option>
                
                <option value="/api/extension-capabilities/theming" >Theming</option>
                
                <option value="/api/extension-capabilities/extending-workbench" >Extending Workbench</option>
                
              </optgroup>
              
              <optgroup label="Extension Guides">
            
                <option value="/api/extension-guides/overview" >Overview</option>
                
                <option value="/api/extension-guides/command" >Command</option>
                
                <option value="/api/extension-guides/color-theme" >Color Theme</option>
                
                <option value="/api/extension-guides/file-icon-theme" >File Icon Theme</option>
                
                <option value="/api/extension-guides/product-icon-theme" >Product Icon Theme</option>
                
                <option value="/api/extension-guides/tree-view" >Tree View</option>
                
                <option value="/api/extension-guides/webview" >Webview</option>
                
                <option value="/api/extension-guides/custom-editors" >Custom Editors</option>
                
                <option value="/api/extension-guides/virtual-documents" >Virtual Documents</option>
                
                <option value="/api/extension-guides/task-provider" >Task Provider</option>
                
                <option value="/api/extension-guides/scm-provider" >Source Control</option>
                
                <option value="/api/extension-guides/debugger-extension" >Debugger Extension</option>
                
                <option value="/api/extension-guides/markdown-extension" >Markdown Extension</option>
                
                <option value="/api/extension-guides/custom-data-extension" >Custom Data Extension</option>
                
              </optgroup>
              
              <optgroup label="Language Extensions">
            
                <option value="/api/language-extensions/overview" >Overview</option>
                
                <option value="/api/language-extensions/syntax-highlight-guide" >Syntax Highlight Guide</option>
                
                <option value="/api/language-extensions/semantic-highlight-guide" >Semantic Highlight Guide</option>
                
                <option value="/api/language-extensions/snippet-guide" >Snippet Guide</option>
                
                <option value="/api/language-extensions/language-configuration-guide" >Language Configuration Guide</option>
                
                <option value="/api/language-extensions/programmatic-language-features" >Programmatic Language Features</option>
                
                <option value="/api/language-extensions/language-server-extension-guide" selected>Language Server Extension Guide</option>
                
                <option value="/api/language-extensions/embedded-languages" >Embedded Languages</option>
                
              </optgroup>
              
              <optgroup label="Advanced Topics">
            
                <option value="/api/advanced-topics/extension-host" >Extension Host</option>
                
                <option value="/api/advanced-topics/remote-extensions" >Remote Development and Codespaces</option>
                
                <option value="/api/advanced-topics/using-proposed-api" >Using Proposed API</option>
                
                <option value="/api/advanced-topics/tslint-eslint-migration" >Migrate from TSLint to ESLint</option>
                
              </optgroup>
              
              <optgroup label="References">
            
                <option value="/api/references/vscode-api" >VS Code API </option>
                
                <option value="/api/references/contribution-points" >Contribution Points</option>
                
                <option value="/api/references/activation-events" >Activation Events</option>
                
                <option value="/api/references/extension-manifest" >Extension Manifest</option>
                
                <option value="/api/references/commands" >Commands</option>
                
                <option value="/api/references/theme-color" >Theme Color</option>
                
                <option value="/api/references/icons-in-labels" >Product Icon Reference</option>
                
                <option value="/api/references/document-selector" >Document Selector</option>
                
              </optgroup>
              
            	</select>
            </nav>		</div>
		<div class="col-sm-9 col-md-8 body">
			<div class="edit-github pull-right">
				<a href="https://github.com/Microsoft/vscode-docs/blob/master/api/language-extensions/language-server-extension-guide.md" tabindex="-1">
					<button type="button" class="btn btn-default" aria-label="Edit current document on GitHub"><span class="glyphicon glyphicon-pencil"></span><i>&nbsp;</i><span class="hidden-xs">Edit</span></button>
				</a>
			</div>
			<h1>Language Server Extension Guide</h1>
<p>As you have seen in the <a href="/api/language-extensions/programmatic-language-features">Programmatic Language Features</a> topic, it's possible to implement Language Features by directly using <code>languages.*</code> API. Language Server Extension, however, provides an alternative way of implementing such language support.</p>
<p>This topic:</p>
<ul>
<li>Explains the benefits of Language Server Extension.</li>
<li>Walks you through building a Language Server using the <a href="https://github.com/Microsoft/vscode-languageserver-node" class="external-link" target="_blank"><code>Microsoft/vscode-languageserver-node</code></a> library. You can also jump directly to the code in <a href="https://github.com/Microsoft/vscode-extension-samples/tree/master/lsp-sample" class="external-link" target="_blank">lsp-sample</a>.</li>
</ul>
<h2 id="why-language-server" data-needslink="why-language-server">Why Language Server?</h2>
<p>Language Server is a special kind of Visual Studio Code extension that powers the editing experience for many programming languages. With Language Servers, you can implement autocomplete, error-checking (diagnostics), jump-to-definition, and many other <a href="/api/language-extensions/programmatic-language-features">language features</a> supported in VS Code.</p>
<p>However, while implementing support for language features in VS Code, we found three common problems:</p>
<p>First, Language Servers are usually implemented in their native programming languages, and that presents a challenge in integrating them with VS Code, which has a Node.js runtime.</p>
<p>Additionally, language features can be resource intensive. For example, to correctly validate a file, Language Server needs to parse a large amount of files, build up Abstract Syntax Trees for them and perform static program analysis. Those operations could incur significant CPU and memory usage and we need to ensure that VS Code's performance remains unaffected.</p>
<p>Finally, integrating multiple language toolings with multiple code editors could involve significant effort. From language toolings' perspective, they need to adapt to code editors with different APIs. From code editors' perspective, they cannot expect any uniform API from language toolings. This makes implementing language support for <code>M</code> languages in <code>N</code> code editors the work of <code>M * N</code>.</p>
<p>To solve those problems, Microsoft specified <a href="https://microsoft.github.io/language-server-protocol" class="external-link" target="_blank">Language Server Protocol</a> which standardizes the communication between language tooling and code editor. This way, Language Servers can be implemented in any language and run in their own process to avoid performance cost, as they communicate with the code editor through the Language Server Protocol. Furthermore, any LSP-compliant language toolings can integrate with multiple LSP-compliant code editors, and any LSP-compliant code editors can easily pick up multiple LSP-compliant language toolings. LSP is a win for both language tooling providers and code editor vendors!</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/lsp-languages-editors.png" alt="LSP Languages and Editors"></p>
<p>In this guide, we will:</p>
<ul>
<li>Explain how to build a Language Server extension in VS Code using the provided <a href="https://github.com/Microsoft/vscode-languageserver-node" class="external-link" target="_blank">Node SDK</a>.</li>
<li>Explain how to run, debug, log, and test the Language Server extension.</li>
<li>Point you to some advanced topics on Language Servers.</li>
</ul>
<h2 id="implementing-a-language-server" data-needslink="implementing-a-language-server">Implementing a Language Server</h2>
<h3 id="overview" data-needslink="overview">Overview</h3>
<p>In VS Code, a language server has two parts:</p>
<ul>
<li>Language Client: A normal VS Code extension written in JavaScript / TypeScript. This extension has access to all <a href="/api/references/vscode-api">VS Code Namespace API</a>.</li>
<li>Language Server: A language analysis tool running in a separate process.</li>
</ul>
<p>As briefly stated above there are two benefits of running the Language Server in a separate process:</p>
<ul>
<li>The analysis tool can be implemented in any languages, as long as it can communicate with the Language Client following the Language Server Protocol.</li>
<li>As language analysis tools are often heavy on CPU and Memory usage, running them in separate process avoids performance cost.</li>
</ul>
<p>Here is an illustration of VS Code running two Language Server extensions. The HTML Language Client and PHP Language Client are normal VS Code extensions written in TypeScript. Each of them instantiates a corresponding Language Server and communicates with them through LSP. Although the PHP Language Server is written in PHP, it can still communicate with the PHP Language Client through LSP.</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/lsp-illustration.png" alt="LSP Illustration"></p>
<p>This guide will teach you how to build a Language Client / Server using our <a href="https://github.com/Microsoft/vscode-languageserver-node" class="external-link" target="_blank">Node SDK</a>. The remaining document assumes that you are familiar with VS Code <a href="/api">Extension API</a>.</p>
<h3 id="lsp-sample-a-simple-language-server-for-plain-text-files" data-needslink="lsp-sample-a-simple-language-server-for-plain-text-files">LSP Sample - A simple Language Server for plain text files</h3>
<p>Let's build a simple Language Server extension that implements autocomplete and diagnostics for plain text files. We will also cover the syncing of configurations between Client / Server.</p>
<p>If you prefer to jump right into the code:</p>
<ul>
<li><strong><a href="https://github.com/Microsoft/vscode-extension-samples/tree/master/lsp-sample" class="external-link" target="_blank">lsp-sample</a></strong>: Heavily documented source code for this guide.</li>
<li><strong><a href="https://github.com/Microsoft/vscode-extension-samples/tree/master/lsp-multi-server-sample" class="external-link" target="_blank">lsp-multi-server-sample</a></strong>: A heavily documented, advanced version of <strong>lsp-sample</strong> that starts a different server instance per workspace folder to support the <a href="/docs/editor/multi-root-workspaces">multi-root workspace</a> feature in VS Code.</li>
</ul>
<p>Clone the repository <a href="https://github.com/Microsoft/vscode-extension-samples" class="external-link" target="_blank">Microsoft/vscode-extension-samples</a> and open the sample:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #000000">&gt; git clone https://github.com/Microsoft/vscode-extension-samples.git</span>
<span style="color: #000000">&gt; </span><span style="color: #795E26">cd</span><span style="color: #000000"> vscode-extension-samples/lsp-sample</span>
<span style="color: #000000">&gt; npm install</span>
<span style="color: #000000">&gt; npm run compile</span>
<span style="color: #000000">&gt; code </span><span style="color: #795E26">.</span></code></pre>
<p>The above installs all dependencies and opens the <strong>lsp-sample</strong> workspace containing both the client and server code. Here is a rough overview of the structure of <strong>lsp-sample</strong>:</p>
<pre class="shiki"><code>.
├── client // Language Client
│   ├── src
│   │   ├── test // End to End tests for Language Client / Server
│   │   └── extension.ts // Language Client entry point
├── package.json // The extension manifest
└── server // Language Server
    └── src
        └── server.ts // Language Server entry point
</code></pre>
<h3 id="explaining-the-language-client" data-needslink="explaining-the-language-client">Explaining the 'Language Client'</h3>
<p>Let's first take a look at <code>/package.json</code>, which describes the capabilities of the Language Client. There are three interesting sections:</p>
<p>First look the <a href="/api/references/activation-events"><code>activationEvents</code></a>:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #A31515">"activationEvents"</span><span style="color: #000000">: [</span>
<span style="color: #000000">    </span><span style="color: #A31515">"onLanguage:plaintext"</span>
<span style="color: #000000">]</span></code></pre>
<p>This section tells VS Code to activate the extension as soon as a plain text file is opened (for example a file with the extension <code>.txt</code>).</p>
<p>Next look at the <a href="/api/references/contribution-points#contributes.configuration"><code>configuration</code></a> section:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #A31515">"configuration"</span><span style="color: #000000">: {</span>
<span style="color: #000000">    </span><span style="color: #0451A5">"type"</span><span style="color: #000000">: </span><span style="color: #A31515">"object"</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #0451A5">"title"</span><span style="color: #000000">: </span><span style="color: #A31515">"Example configuration"</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #0451A5">"properties"</span><span style="color: #000000">: {</span>
<span style="color: #000000">        </span><span style="color: #0451A5">"languageServerExample.maxNumberOfProblems"</span><span style="color: #000000">: {</span>
<span style="color: #000000">            </span><span style="color: #0451A5">"scope"</span><span style="color: #000000">: </span><span style="color: #A31515">"resource"</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #0451A5">"type"</span><span style="color: #000000">: </span><span style="color: #A31515">"number"</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #0451A5">"default"</span><span style="color: #000000">: </span><span style="color: #098658">100</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #0451A5">"description"</span><span style="color: #000000">: </span><span style="color: #A31515">"Controls the maximum number of problems produced by the server."</span>
<span style="color: #000000">        }</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">}</span></code></pre>
<p>This section contributes <code>configuration</code> settings to VS Code. The example will explain how these settings are sent over to the language server on startup and on every change of the settings.</p>
<p>The actual Language Client code and the corresponding <code>package.json</code> is in the <code>/client</code> folder. The interesting part in the <code>/client/package.json</code> file is that it adds a dependency to the <code>vscode</code> extension host API and the <code>vscode-languageclient</code> library:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #A31515">"dependencies"</span><span style="color: #000000">: {</span>
<span style="color: #000000">    </span><span style="color: #0451A5">"vscode"</span><span style="color: #000000">: </span><span style="color: #A31515">"^1.1.18"</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #0451A5">"vscode-languageclient"</span><span style="color: #000000">: </span><span style="color: #A31515">"^4.1.4"</span>
<span style="color: #000000">}</span></code></pre>
<p>As mentioned, the client is implemented as a normal VS Code extension, and it has access to all VS Code namespace API.</p>
<p>Below is the content of the corresponding extension.ts file, which is the entry of the <strong>lsp-sample</strong> extension:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #0000FF">import</span><span style="color: #000000"> </span><span style="color: #0000FF">*</span><span style="color: #000000"> </span><span style="color: #0000FF">as</span><span style="color: #000000"> </span><span style="color: #001080">path</span><span style="color: #000000"> </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'path'</span><span style="color: #000000">;</span>
<span style="color: #0000FF">import</span><span style="color: #000000"> { </span><span style="color: #001080">workspace</span><span style="color: #000000">, </span><span style="color: #001080">ExtensionContext</span><span style="color: #000000"> } </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'vscode'</span><span style="color: #000000">;</span>

<span style="color: #0000FF">import</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #001080">LanguageClient</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">LanguageClientOptions</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">ServerOptions</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">TransportKind</span>
<span style="color: #000000">} </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'vscode-languageclient'</span><span style="color: #000000">;</span>

<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">client</span><span style="color: #000000">: </span><span style="color: #267F99">LanguageClient</span><span style="color: #000000">;</span>

<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">activate</span><span style="color: #000000">(</span><span style="color: #001080">context</span><span style="color: #000000">: </span><span style="color: #267F99">ExtensionContext</span><span style="color: #000000">) {</span>
<span style="color: #000000">  </span><span style="color: #008000">// The server is implemented in node</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">serverModule</span><span style="color: #000000"> = </span><span style="color: #001080">context</span><span style="color: #000000">.</span><span style="color: #795E26">asAbsolutePath</span><span style="color: #000000">(path.</span><span style="color: #795E26">join</span><span style="color: #000000">(</span><span style="color: #A31515">'server'</span><span style="color: #000000">, </span><span style="color: #A31515">'out'</span><span style="color: #000000">, </span><span style="color: #A31515">'server.js'</span><span style="color: #000000">));</span>
<span style="color: #000000">  </span><span style="color: #008000">// The debug options for the server</span>
<span style="color: #000000">  </span><span style="color: #008000">// --inspect=6009: runs the server in Node's Inspector mode so VS Code can attach to the server for debugging</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">debugOptions</span><span style="color: #000000"> = { </span><span style="color: #001080">execArgv:</span><span style="color: #000000"> [</span><span style="color: #A31515">'--nolazy'</span><span style="color: #000000">, </span><span style="color: #A31515">'--inspect=6009'</span><span style="color: #000000">] };</span>

<span style="color: #000000">  </span><span style="color: #008000">// If the extension is launched in debug mode then the debug server options are used</span>
<span style="color: #000000">  </span><span style="color: #008000">// Otherwise the run options are used</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">serverOptions</span><span style="color: #000000">: </span><span style="color: #267F99">ServerOptions</span><span style="color: #000000"> = {</span>
<span style="color: #000000">    </span><span style="color: #001080">run:</span><span style="color: #000000"> { </span><span style="color: #001080">module:</span><span style="color: #000000"> </span><span style="color: #001080">serverModule</span><span style="color: #000000">, </span><span style="color: #001080">transport:</span><span style="color: #000000"> </span><span style="color: #001080">TransportKind</span><span style="color: #000000">.</span><span style="color: #001080">ipc</span><span style="color: #000000"> },</span>
<span style="color: #000000">    </span><span style="color: #001080">debug:</span><span style="color: #000000"> {</span>
<span style="color: #000000">      </span><span style="color: #001080">module:</span><span style="color: #000000"> </span><span style="color: #001080">serverModule</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">transport:</span><span style="color: #000000"> </span><span style="color: #001080">TransportKind</span><span style="color: #000000">.</span><span style="color: #001080">ipc</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">options:</span><span style="color: #000000"> </span><span style="color: #001080">debugOptions</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">  };</span>

<span style="color: #000000">  </span><span style="color: #008000">// Options to control the language client</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">clientOptions</span><span style="color: #000000">: </span><span style="color: #267F99">LanguageClientOptions</span><span style="color: #000000"> = {</span>
<span style="color: #000000">    </span><span style="color: #008000">// Register the server for plain text documents</span>
<span style="color: #000000">    </span><span style="color: #001080">documentSelector:</span><span style="color: #000000"> [{ </span><span style="color: #001080">scheme:</span><span style="color: #000000"> </span><span style="color: #A31515">'file'</span><span style="color: #000000">, </span><span style="color: #001080">language:</span><span style="color: #000000"> </span><span style="color: #A31515">'plaintext'</span><span style="color: #000000"> }],</span>
<span style="color: #000000">    </span><span style="color: #001080">synchronize:</span><span style="color: #000000"> {</span>
<span style="color: #000000">      </span><span style="color: #008000">// Notify the server about file changes to '.clientrc files contained in the workspace</span>
<span style="color: #000000">      </span><span style="color: #001080">fileEvents:</span><span style="color: #000000"> </span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #795E26">createFileSystemWatcher</span><span style="color: #000000">(</span><span style="color: #A31515">'**/.clientrc'</span><span style="color: #000000">)</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">  };</span>

<span style="color: #000000">  </span><span style="color: #008000">// Create the language client and start the client.</span>
<span style="color: #000000">  </span><span style="color: #001080">client</span><span style="color: #000000"> = </span><span style="color: #0000FF">new</span><span style="color: #000000"> </span><span style="color: #267F99">LanguageClient</span><span style="color: #000000">(</span>
<span style="color: #000000">    </span><span style="color: #A31515">'languageServerExample'</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #A31515">'Language Server Example'</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #001080">serverOptions</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #001080">clientOptions</span>
<span style="color: #000000">  );</span>

<span style="color: #000000">  </span><span style="color: #008000">// Start the client. This will also launch the server</span>
<span style="color: #000000">  </span><span style="color: #001080">client</span><span style="color: #000000">.</span><span style="color: #795E26">start</span><span style="color: #000000">();</span>
<span style="color: #000000">}</span>

<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">deactivate</span><span style="color: #000000">(): </span><span style="color: #267F99">Thenable</span><span style="color: #000000">&lt;</span><span style="color: #267F99">void</span><span style="color: #000000">&gt; | </span><span style="color: #267F99">undefined</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (!</span><span style="color: #001080">client</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #0000FF">undefined</span><span style="color: #000000">;</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">  </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #001080">client</span><span style="color: #000000">.</span><span style="color: #795E26">stop</span><span style="color: #000000">();</span>
<span style="color: #000000">}</span></code></pre>
<h3 id="explaining-the-language-server" data-needslink="explaining-the-language-server">Explaining the 'Language Server'</h3>
<blockquote>
<p><strong>Note:</strong> The 'Server' implementation cloned from the GitHub repository has the final walkthrough implementation. To follow the walkthrough, you can create a new <code>server.ts</code> or modify the contents of the cloned version.</p>
</blockquote>
<p>In the example, the server is also implemented in TypeScript and executed using Node.js. Since VS Code already ships with a Node.js runtime, there is no need to provide your own, unless you have specific requirements for the runtime.</p>
<p>The source code for the Language Server is at <code>/server</code>. The interesting section in the server's <code>package.json</code> file is:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #A31515">"dependencies"</span><span style="color: #000000">: {</span>
<span style="color: #000000">    </span><span style="color: #0451A5">"vscode-languageserver"</span><span style="color: #000000">: </span><span style="color: #A31515">"^4.1.3"</span>
<span style="color: #000000">}</span></code></pre>
<p>This pulls in the <code>vscode-languageserver</code> library.</p>
<p>Below is a server implementation that uses the provided simple text document manager that synchronizes text documents by always sending the file's full content from VS Code to the server.</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #0000FF">import</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #001080">createConnection</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">TextDocuments</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">TextDocument</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">Diagnostic</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">DiagnosticSeverity</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">ProposedFeatures</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">InitializeParams</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">DidChangeConfigurationNotification</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">CompletionItem</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">TextDocumentPositionParams</span>
<span style="color: #000000">} </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'vscode-languageserver'</span><span style="color: #000000">;</span>

<span style="color: #008000">// Create a connection for the server. The connection uses Node's IPC as a transport.</span>
<span style="color: #008000">// Also include all preview / proposed LSP features.</span>
<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">connection</span><span style="color: #000000"> = </span><span style="color: #795E26">createConnection</span><span style="color: #000000">(</span><span style="color: #001080">ProposedFeatures</span><span style="color: #000000">.</span><span style="color: #001080">all</span><span style="color: #000000">);</span>

<span style="color: #008000">// Create a simple text document manager. The text document manager</span>
<span style="color: #008000">// supports full document sync only</span>
<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">documents</span><span style="color: #000000">: </span><span style="color: #267F99">TextDocuments</span><span style="color: #000000"> = </span><span style="color: #0000FF">new</span><span style="color: #000000"> </span><span style="color: #267F99">TextDocuments</span><span style="color: #000000">();</span>

<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000">: </span><span style="color: #267F99">boolean</span><span style="color: #000000"> = </span><span style="color: #0000FF">false</span><span style="color: #000000">;</span>
<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">hasWorkspaceFolderCapability</span><span style="color: #000000">: </span><span style="color: #267F99">boolean</span><span style="color: #000000"> = </span><span style="color: #0000FF">false</span><span style="color: #000000">;</span>
<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">hasDiagnosticRelatedInformationCapability</span><span style="color: #000000">: </span><span style="color: #267F99">boolean</span><span style="color: #000000"> = </span><span style="color: #0000FF">false</span><span style="color: #000000">;</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onInitialize</span><span style="color: #000000">((</span><span style="color: #001080">params</span><span style="color: #000000">: </span><span style="color: #267F99">InitializeParams</span><span style="color: #000000">) </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">capabilities</span><span style="color: #000000"> = </span><span style="color: #001080">params</span><span style="color: #000000">.</span><span style="color: #001080">capabilities</span><span style="color: #000000">;</span>

<span style="color: #000000">  </span><span style="color: #008000">// Does the client support the `workspace/configuration` request?</span>
<span style="color: #000000">  </span><span style="color: #008000">// If not, we will fall back using global settings</span>
<span style="color: #000000">  </span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000"> =</span>
<span style="color: #000000">    </span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000"> && !!</span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #001080">configuration</span><span style="color: #000000">;</span>
<span style="color: #000000">  </span><span style="color: #001080">hasWorkspaceFolderCapability</span><span style="color: #000000"> =</span>
<span style="color: #000000">    </span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000"> && !!</span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #001080">workspaceFolders</span><span style="color: #000000">;</span>
<span style="color: #000000">  </span><span style="color: #001080">hasDiagnosticRelatedInformationCapability</span><span style="color: #000000"> =</span>
<span style="color: #000000">    </span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">textDocument</span><span style="color: #000000"> &&</span>
<span style="color: #000000">    </span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">publishDiagnostics</span><span style="color: #000000"> &&</span>
<span style="color: #000000">    </span><span style="color: #001080">capabilities</span><span style="color: #000000">.</span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">publishDiagnostics</span><span style="color: #000000">.</span><span style="color: #001080">relatedInformation</span><span style="color: #000000">;</span>

<span style="color: #000000">  </span><span style="color: #0000FF">return</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #001080">capabilities:</span><span style="color: #000000"> {</span>
<span style="color: #000000">      </span><span style="color: #001080">textDocumentSync:</span><span style="color: #000000"> </span><span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #001080">syncKind</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #008000">// Tell the client that the server supports code completion</span>
<span style="color: #000000">      </span><span style="color: #001080">completionProvider:</span><span style="color: #000000"> {</span>
<span style="color: #000000">        </span><span style="color: #001080">resolveProvider:</span><span style="color: #000000"> </span><span style="color: #0000FF">true</span>
<span style="color: #000000">      }</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">  };</span>
<span style="color: #000000">});</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onInitialized</span><span style="color: #000000">(() </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #008000">// Register for all configuration changes.</span>
<span style="color: #000000">    </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #001080">client</span><span style="color: #000000">.</span><span style="color: #795E26">register</span><span style="color: #000000">(</span><span style="color: #001080">DidChangeConfigurationNotification</span><span style="color: #000000">.</span><span style="color: #001080">type</span><span style="color: #000000">, </span><span style="color: #0000FF">undefined</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasWorkspaceFolderCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeWorkspaceFolders</span><span style="color: #000000">(</span><span style="color: #001080">_event</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">      </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #001080">console</span><span style="color: #000000">.</span><span style="color: #795E26">log</span><span style="color: #000000">(</span><span style="color: #A31515">'Workspace folder change event received.'</span><span style="color: #000000">);</span>
<span style="color: #000000">    });</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">});</span>

<span style="color: #008000">// The example settings</span>
<span style="color: #0000FF">interface</span><span style="color: #000000"> </span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #001080">maxNumberOfProblems</span><span style="color: #000000">: </span><span style="color: #267F99">number</span><span style="color: #000000">;</span>
<span style="color: #000000">}</span>

<span style="color: #008000">// The global settings, used when the `workspace/configuration` request is not supported by the client.</span>
<span style="color: #008000">// Please note that this is not the case when using this server with the client provided in this example</span>
<span style="color: #008000">// but could happen with other clients.</span>
<span style="color: #0000FF">const</span><span style="color: #000000"> </span><span style="color: #001080">defaultSettings</span><span style="color: #000000">: </span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000"> = { </span><span style="color: #001080">maxNumberOfProblems:</span><span style="color: #000000"> </span><span style="color: #098658">1000</span><span style="color: #000000"> };</span>
<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">globalSettings</span><span style="color: #000000">: </span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000"> = </span><span style="color: #001080">defaultSettings</span><span style="color: #000000">;</span>

<span style="color: #008000">// Cache the settings of all open documents</span>
<span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">documentSettings</span><span style="color: #000000">: </span><span style="color: #267F99">Map</span><span style="color: #000000">&lt;</span><span style="color: #267F99">string</span><span style="color: #000000">, </span><span style="color: #267F99">Thenable</span><span style="color: #000000">&lt;</span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000">&gt;&gt; = </span><span style="color: #0000FF">new</span><span style="color: #000000"> </span><span style="color: #267F99">Map</span><span style="color: #000000">();</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeConfiguration</span><span style="color: #000000">(</span><span style="color: #001080">change</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #008000">// Reset all cached document settings</span>
<span style="color: #000000">    </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">clear</span><span style="color: #000000">();</span>
<span style="color: #000000">  } </span><span style="color: #0000FF">else</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #001080">globalSettings</span><span style="color: #000000"> = &lt;</span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000">&gt;(</span>
<span style="color: #000000">      (</span><span style="color: #001080">change</span><span style="color: #000000">.</span><span style="color: #001080">settings</span><span style="color: #000000">.</span><span style="color: #001080">languageServerExample</span><span style="color: #000000"> || </span><span style="color: #001080">defaultSettings</span><span style="color: #000000">)</span>
<span style="color: #000000">    );</span>
<span style="color: #000000">  }</span>

<span style="color: #000000">  </span><span style="color: #008000">// Revalidate all open text documents</span>
<span style="color: #000000">  </span><span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #795E26">all</span><span style="color: #000000">().</span><span style="color: #795E26">forEach</span><span style="color: #000000">(</span><span style="color: #001080">validateTextDocument</span><span style="color: #000000">);</span>
<span style="color: #000000">});</span>

<span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">getDocumentSettings</span><span style="color: #000000">(</span><span style="color: #001080">resource</span><span style="color: #000000">: </span><span style="color: #267F99">string</span><span style="color: #000000">): </span><span style="color: #267F99">Thenable</span><span style="color: #000000">&lt;</span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000">&gt; {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (!</span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #267F99">Promise</span><span style="color: #000000">.</span><span style="color: #795E26">resolve</span><span style="color: #000000">(</span><span style="color: #001080">globalSettings</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">result</span><span style="color: #000000"> = </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">get</span><span style="color: #000000">(</span><span style="color: #001080">resource</span><span style="color: #000000">);</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (!</span><span style="color: #001080">result</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #001080">result</span><span style="color: #000000"> = </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #795E26">getConfiguration</span><span style="color: #000000">({</span>
<span style="color: #000000">      </span><span style="color: #001080">scopeUri:</span><span style="color: #000000"> </span><span style="color: #001080">resource</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">section:</span><span style="color: #000000"> </span><span style="color: #A31515">'languageServerExample'</span>
<span style="color: #000000">    });</span>
<span style="color: #000000">    </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">set</span><span style="color: #000000">(</span><span style="color: #001080">resource</span><span style="color: #000000">, </span><span style="color: #001080">result</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">  </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #001080">result</span><span style="color: #000000">;</span>
<span style="color: #000000">}</span>

<span style="color: #008000">// Only keep settings for open documents</span>
<span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #795E26">onDidClose</span><span style="color: #000000">(</span><span style="color: #001080">e</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">delete</span><span style="color: #000000">(</span><span style="color: #001080">e</span><span style="color: #000000">.</span><span style="color: #001080">document</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">);</span>
<span style="color: #000000">});</span>

<span style="color: #008000">// The content of a text document has changed. This event is emitted</span>
<span style="color: #008000">// when the text document first opened or when its content has changed.</span>
<span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeContent</span><span style="color: #000000">(</span><span style="color: #001080">change</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #795E26">validateTextDocument</span><span style="color: #000000">(</span><span style="color: #001080">change</span><span style="color: #000000">.</span><span style="color: #001080">document</span><span style="color: #000000">);</span>
<span style="color: #000000">});</span>

<span style="color: #0000FF">async</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">validateTextDocument</span><span style="color: #000000">(</span><span style="color: #001080">textDocument</span><span style="color: #000000">: </span><span style="color: #267F99">TextDocument</span><span style="color: #000000">): </span><span style="color: #267F99">Promise</span><span style="color: #000000">&lt;</span><span style="color: #267F99">void</span><span style="color: #000000">&gt; {</span>
<span style="color: #000000">  </span><span style="color: #008000">// In this simple example we get the settings for every validate run.</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">settings</span><span style="color: #000000"> = </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #795E26">getDocumentSettings</span><span style="color: #000000">(</span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">);</span>

<span style="color: #000000">  </span><span style="color: #008000">// The validator creates diagnostics for all uppercase words length 2 and more</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">text</span><span style="color: #000000"> = </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">getText</span><span style="color: #000000">();</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">pattern</span><span style="color: #000000"> =</span><span style="color: #A31515"> /</span><span style="color: #FF0000">\b</span><span style="color: #D16969">[</span><span style="color: #811F3F">A-Z</span><span style="color: #D16969">]</span><span style="color: #000000">{2,}</span><span style="color: #FF0000">\b</span><span style="color: #A31515">/</span><span style="color: #0000FF">g</span><span style="color: #000000">;</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">m</span><span style="color: #000000">: </span><span style="color: #267F99">RegExpExecArray</span><span style="color: #000000">;</span>

<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">problems</span><span style="color: #000000"> = </span><span style="color: #098658">0</span><span style="color: #000000">;</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">diagnostics</span><span style="color: #000000">: </span><span style="color: #267F99">Diagnostic</span><span style="color: #000000">[] = [];</span>
<span style="color: #000000">  </span><span style="color: #0000FF">while</span><span style="color: #000000"> ((</span><span style="color: #001080">m</span><span style="color: #000000"> = </span><span style="color: #001080">pattern</span><span style="color: #000000">.</span><span style="color: #795E26">exec</span><span style="color: #000000">(</span><span style="color: #001080">text</span><span style="color: #000000">)) && </span><span style="color: #001080">problems</span><span style="color: #000000"> &lt; </span><span style="color: #001080">settings</span><span style="color: #000000">.</span><span style="color: #001080">maxNumberOfProblems</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #001080">problems</span><span style="color: #000000">++;</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">diagnostic</span><span style="color: #000000">: </span><span style="color: #267F99">Diagnostic</span><span style="color: #000000"> = {</span>
<span style="color: #000000">      </span><span style="color: #001080">severity:</span><span style="color: #000000"> </span><span style="color: #001080">DiagnosticSeverity</span><span style="color: #000000">.</span><span style="color: #001080">Warning</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">range:</span><span style="color: #000000"> {</span>
<span style="color: #000000">        </span><span style="color: #001080">start:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">positionAt</span><span style="color: #000000">(</span><span style="color: #001080">m</span><span style="color: #000000">.</span><span style="color: #001080">index</span><span style="color: #000000">),</span>
<span style="color: #000000">        </span><span style="color: #001080">end:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">positionAt</span><span style="color: #000000">(</span><span style="color: #001080">m</span><span style="color: #000000">.</span><span style="color: #001080">index</span><span style="color: #000000"> + </span><span style="color: #001080">m</span><span style="color: #000000">[</span><span style="color: #098658">0</span><span style="color: #000000">].</span><span style="color: #001080">length</span><span style="color: #000000">)</span>
<span style="color: #000000">      },</span>
<span style="color: #000000">      </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">`</span><span style="color: #0000FF">${</span><span style="color: #001080">m</span><span style="color: #000000">[</span><span style="color: #098658">0</span><span style="color: #000000">]</span><span style="color: #0000FF">}</span><span style="color: #A31515"> is all uppercase.`</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">source:</span><span style="color: #000000"> </span><span style="color: #A31515">'ex'</span>
<span style="color: #000000">    };</span>
<span style="color: #000000">    </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasDiagnosticRelatedInformationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">      </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">relatedInformation</span><span style="color: #000000"> = [</span>
<span style="color: #000000">        {</span>
<span style="color: #000000">          </span><span style="color: #001080">location:</span><span style="color: #000000"> {</span>
<span style="color: #000000">            </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #001080">range:</span><span style="color: #000000"> </span><span style="color: #267F99">Object</span><span style="color: #000000">.</span><span style="color: #795E26">assign</span><span style="color: #000000">({}, </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">range</span><span style="color: #000000">)</span>
<span style="color: #000000">          },</span>
<span style="color: #000000">          </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">'Spelling matters'</span>
<span style="color: #000000">        },</span>
<span style="color: #000000">        {</span>
<span style="color: #000000">          </span><span style="color: #001080">location:</span><span style="color: #000000"> {</span>
<span style="color: #000000">            </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #001080">range:</span><span style="color: #000000"> </span><span style="color: #267F99">Object</span><span style="color: #000000">.</span><span style="color: #795E26">assign</span><span style="color: #000000">({}, </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">range</span><span style="color: #000000">)</span>
<span style="color: #000000">          },</span>
<span style="color: #000000">          </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">'Particularly for names'</span>
<span style="color: #000000">        }</span>
<span style="color: #000000">      ];</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">    </span><span style="color: #001080">diagnostics</span><span style="color: #000000">.</span><span style="color: #795E26">push</span><span style="color: #000000">(</span><span style="color: #001080">diagnostic</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>

<span style="color: #000000">  </span><span style="color: #008000">// Send the computed diagnostics to VS Code.</span>
<span style="color: #000000">  </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">sendDiagnostics</span><span style="color: #000000">({ </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">, </span><span style="color: #001080">diagnostics</span><span style="color: #000000"> });</span>
<span style="color: #000000">}</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeWatchedFiles</span><span style="color: #000000">(</span><span style="color: #001080">_change</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #008000">// Monitored files have change in VS Code</span>
<span style="color: #000000">  </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #001080">console</span><span style="color: #000000">.</span><span style="color: #795E26">log</span><span style="color: #000000">(</span><span style="color: #A31515">'We received a file change event'</span><span style="color: #000000">);</span>
<span style="color: #000000">});</span>

<span style="color: #008000">// This handler provides the initial list of the completion items.</span>
<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onCompletion</span><span style="color: #000000">(</span>
<span style="color: #000000">  (</span><span style="color: #001080">_textDocumentPosition</span><span style="color: #000000">: </span><span style="color: #267F99">TextDocumentPositionParams</span><span style="color: #000000">): </span><span style="color: #267F99">CompletionItem</span><span style="color: #000000">[] </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #008000">// The pass parameter contains the position of the text document in</span>
<span style="color: #000000">    </span><span style="color: #008000">// which code complete got requested. For the example we ignore this</span>
<span style="color: #000000">    </span><span style="color: #008000">// info and always provide the same completion items.</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> [</span>
<span style="color: #000000">      {</span>
<span style="color: #000000">        </span><span style="color: #001080">label:</span><span style="color: #000000"> </span><span style="color: #A31515">'TypeScript'</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">kind:</span><span style="color: #000000"> </span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">.</span><span style="color: #001080">Text</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">data:</span><span style="color: #000000"> </span><span style="color: #098658">1</span>
<span style="color: #000000">      },</span>
<span style="color: #000000">      {</span>
<span style="color: #000000">        </span><span style="color: #001080">label:</span><span style="color: #000000"> </span><span style="color: #A31515">'JavaScript'</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">kind:</span><span style="color: #000000"> </span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">.</span><span style="color: #001080">Text</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">data:</span><span style="color: #000000"> </span><span style="color: #098658">2</span>
<span style="color: #000000">      }</span>
<span style="color: #000000">    ];</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">);</span>

<span style="color: #008000">// This handler resolves additional information for the item selected in</span>
<span style="color: #008000">// the completion list.</span>
<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onCompletionResolve</span><span style="color: #000000">(</span>
<span style="color: #000000">  (</span><span style="color: #001080">item</span><span style="color: #000000">: </span><span style="color: #267F99">CompletionItem</span><span style="color: #000000">): </span><span style="color: #267F99">CompletionItem</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">data</span><span style="color: #000000"> === </span><span style="color: #098658">1</span><span style="color: #000000">) {</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">detail</span><span style="color: #000000"> = </span><span style="color: #A31515">'TypeScript details'</span><span style="color: #000000">;</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">documentation</span><span style="color: #000000"> = </span><span style="color: #A31515">'TypeScript documentation'</span><span style="color: #000000">;</span>
<span style="color: #000000">    } </span><span style="color: #0000FF">else</span><span style="color: #000000"> </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">data</span><span style="color: #000000"> === </span><span style="color: #098658">2</span><span style="color: #000000">) {</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">detail</span><span style="color: #000000"> = </span><span style="color: #A31515">'JavaScript details'</span><span style="color: #000000">;</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">documentation</span><span style="color: #000000"> = </span><span style="color: #A31515">'JavaScript documentation'</span><span style="color: #000000">;</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #001080">item</span><span style="color: #000000">;</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">);</span>

<span style="color: #008000">/*</span>
<span style="color: #008000">connection.onDidOpenTextDocument((params) =&gt; {</span>
<span style="color: #008000">    // A text document got opened in VS Code.</span>
<span style="color: #008000">    // params.uri uniquely identifies the document. For documents store on disk this is a file URI.</span>
<span style="color: #008000">    // params.text the initial full content of the document.</span>
<span style="color: #008000">    connection.console.log(`${params.textDocument.uri} opened.`);</span>
<span style="color: #008000">});</span>
<span style="color: #008000">connection.onDidChangeTextDocument((params) =&gt; {</span>
<span style="color: #008000">    // The content of a text document did change in VS Code.</span>
<span style="color: #008000">    // params.uri uniquely identifies the document.</span>
<span style="color: #008000">    // params.contentChanges describe the content changes to the document.</span>
<span style="color: #008000">    connection.console.log(`${params.textDocument.uri} changed: ${JSON.stringify(params.contentChanges)}`);</span>
<span style="color: #008000">});</span>
<span style="color: #008000">connection.onDidCloseTextDocument((params) =&gt; {</span>
<span style="color: #008000">    // A text document got closed in VS Code.</span>
<span style="color: #008000">    // params.uri uniquely identifies the document.</span>
<span style="color: #008000">    connection.console.log(`${params.textDocument.uri} closed.`);</span>
<span style="color: #008000">});</span>
<span style="color: #008000">*/</span>

<span style="color: #008000">// Make the text document manager listen on the connection</span>
<span style="color: #008000">// for open, change and close text document events</span>
<span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #795E26">listen</span><span style="color: #000000">(</span><span style="color: #001080">connection</span><span style="color: #000000">);</span>

<span style="color: #008000">// Listen on the connection</span>
<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">listen</span><span style="color: #000000">();</span></code></pre>
<h3 id="adding-a-simple-validation" data-needslink="adding-a-simple-validation">Adding a Simple Validation</h3>
<p>To add document validation to the server, we add a listener to the text document manager that gets called whenever the content of a text document changes. It is then up to the server to decide when the best time is to validate a document. In the example implementation, the server validates the plain text document and flags all occurrences of words that use ALL CAPS. The corresponding code snippet looks like this:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #008000">// The content of a text document has changed. This event is emitted</span>
<span style="color: #008000">// when the text document first opened or when its content has changed.</span>
<span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeContent</span><span style="color: #000000">(</span><span style="color: #0000FF">async</span><span style="color: #000000"> (</span><span style="color: #001080">change</span><span style="color: #000000">) </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #008000">// In this simple example we get the settings for every validate run.</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">settings</span><span style="color: #000000"> = </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #795E26">getDocumentSettings</span><span style="color: #000000">(</span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">);</span>

<span style="color: #000000">    </span><span style="color: #008000">// The validator creates diagnostics for all uppercase words length 2 and more</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">text</span><span style="color: #000000"> = </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">getText</span><span style="color: #000000">();</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">pattern</span><span style="color: #000000"> =</span><span style="color: #A31515"> /</span><span style="color: #FF0000">\b</span><span style="color: #D16969">[</span><span style="color: #811F3F">A-Z</span><span style="color: #D16969">]</span><span style="color: #000000">{2,}</span><span style="color: #FF0000">\b</span><span style="color: #A31515">/</span><span style="color: #0000FF">g</span><span style="color: #000000">;</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">m</span><span style="color: #000000">: </span><span style="color: #267F99">RegExpExecArray</span><span style="color: #000000">;</span>

<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">problems</span><span style="color: #000000"> = </span><span style="color: #098658">0</span><span style="color: #000000">;</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">diagnostics</span><span style="color: #000000">: </span><span style="color: #267F99">Diagnostic</span><span style="color: #000000">[] = [];</span>
<span style="color: #000000">    </span><span style="color: #0000FF">while</span><span style="color: #000000"> ((</span><span style="color: #001080">m</span><span style="color: #000000"> = </span><span style="color: #001080">pattern</span><span style="color: #000000">.</span><span style="color: #795E26">exec</span><span style="color: #000000">(</span><span style="color: #001080">text</span><span style="color: #000000">))) {</span>
<span style="color: #000000">        </span><span style="color: #001080">problems</span><span style="color: #000000">++;</span>
<span style="color: #000000">        </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">diagnostic</span><span style="color: #000000">: </span><span style="color: #267F99">Diagnostic</span><span style="color: #000000"> = {</span>
<span style="color: #000000">            </span><span style="color: #001080">severity:</span><span style="color: #000000"> </span><span style="color: #001080">DiagnosticSeverity</span><span style="color: #000000">.</span><span style="color: #001080">Warning</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #001080">range:</span><span style="color: #000000"> {</span>
<span style="color: #000000">                </span><span style="color: #001080">start:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">positionAt</span><span style="color: #000000">(</span><span style="color: #001080">m</span><span style="color: #000000">.</span><span style="color: #001080">index</span><span style="color: #000000">),</span>
<span style="color: #000000">                </span><span style="color: #001080">end:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">positionAt</span><span style="color: #000000">(</span><span style="color: #001080">m</span><span style="color: #000000">.</span><span style="color: #001080">index</span><span style="color: #000000"> + </span><span style="color: #001080">m</span><span style="color: #000000">[</span><span style="color: #098658">0</span><span style="color: #000000">].</span><span style="color: #001080">length</span><span style="color: #000000">)</span>
<span style="color: #000000">            },</span>
<span style="color: #000000">            </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">`</span><span style="color: #0000FF">${</span><span style="color: #001080">m</span><span style="color: #000000">[</span><span style="color: #098658">0</span><span style="color: #000000">]</span><span style="color: #0000FF">}</span><span style="color: #A31515"> is all uppercase.`</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #001080">source:</span><span style="color: #000000"> </span><span style="color: #A31515">'ex'</span>
<span style="color: #000000">        };</span>
<span style="color: #000000">        </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasDiagnosticRelatedInformationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">            </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">relatedInformation</span><span style="color: #000000"> = [</span>
<span style="color: #000000">                {</span>
<span style="color: #000000">                    </span><span style="color: #001080">location:</span><span style="color: #000000"> {</span>
<span style="color: #000000">                        </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">,</span>
<span style="color: #000000">                        </span><span style="color: #001080">range:</span><span style="color: #000000"> </span><span style="color: #267F99">Object</span><span style="color: #000000">.</span><span style="color: #795E26">assign</span><span style="color: #000000">({}, </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">range</span><span style="color: #000000">)</span>
<span style="color: #000000">                    },</span>
<span style="color: #000000">                    </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">'Spelling matters'</span>
<span style="color: #000000">                },</span>
<span style="color: #000000">                {</span>
<span style="color: #000000">                    </span><span style="color: #001080">location:</span><span style="color: #000000"> {</span>
<span style="color: #000000">                        </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">,</span>
<span style="color: #000000">                        </span><span style="color: #001080">range:</span><span style="color: #000000"> </span><span style="color: #267F99">Object</span><span style="color: #000000">.</span><span style="color: #795E26">assign</span><span style="color: #000000">({}, </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">range</span><span style="color: #000000">)</span>
<span style="color: #000000">                    },</span>
<span style="color: #000000">                    </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">'Particularly for names'</span>
<span style="color: #000000">                }</span>
<span style="color: #000000">            ];</span>
<span style="color: #000000">        }</span>
<span style="color: #000000">        </span><span style="color: #001080">diagnostics</span><span style="color: #000000">.</span><span style="color: #795E26">push</span><span style="color: #000000">(</span><span style="color: #001080">diagnostic</span><span style="color: #000000">);</span>
<span style="color: #000000">    }</span>

<span style="color: #000000">    </span><span style="color: #008000">// Send the computed diagnostics to VS Code.</span>
<span style="color: #000000">    </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">sendDiagnostics</span><span style="color: #000000">({ </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">, </span><span style="color: #001080">diagnostics</span><span style="color: #000000"> });</span>
<span style="color: #000000">}</span></code></pre>
<h3 id="diagnostics-tips-and-tricks" data-needslink="diagnostics-tips-and-tricks">Diagnostics Tips and Tricks</h3>
<ul>
<li>If the start and end positions are the same, VS Code will underline with a squiggle the word at that position.</li>
<li>If you want to underline with a squiggle until the end of the line, then set the character of the end position to Number.MAX_VALUE.</li>
</ul>
<p>To run the Language Server, do the following:</p>
<ul>
<li>press <span class="dynamic-keybinding" data-osx="⇧⌘B" data-win="Ctrl+Shift+B" data-linux="Ctrl+Shift+B"><span class="keybinding">⇧⌘B</span> (Windows, Linux <span class="keybinding">Ctrl+Shift+B</span>)</span> to start the build task. The task compiles both the client and the server.</li>
<li>open the Run view, select the <code>Launch Client</code> launch configuration, and press the <code>Start Debugging</code> button to launch an additional <code>Extension Development Host</code> instance of VS Code that executes the extension code.</li>
<li>Create a test.txt file in the root folder and paste the following content:</li>
</ul>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #000000">TypeScript lets you write JavaScript the way you really want to.</span>
<span style="color: #000000">TypeScript is a typed superset of JavaScript that compiles to plain JavaScript.</span>
<span style="color: #000000">ANY browser. ANY host. ANY OS. Open Source.</span></code></pre>
<p>The <code>Extension Development Host</code> instance will then look like this:</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/validation.png" alt="Validating a text file"></p>
<h3 id="debugging-both-client-and-server" data-needslink="debugging-both-client-and-server">Debugging both Client and Server</h3>
<p>Debugging the client code is as easy as debugging a normal extension. Set a breakpoint in the client code and debug the extension by pressing <span class="dynamic-keybinding" data-osx="F5" data-win="F5" data-linux="F5"><span class="keybinding">F5</span></span>.</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/debugging-client.png" alt="Debugging the client"></p>
<p>Since the server is started by the <code>LanguageClient</code> running in the extension (client), we need to attach a debugger to the running server. To do so, switch to the Run view and select the launch configuration <code>Attach to Server</code> and press <span class="dynamic-keybinding" data-osx="F5" data-win="F5" data-linux="F5"><span class="keybinding">F5</span></span>. This will attach the debugger to the server.</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/debugging-server.png" alt="Debugging the server"></p>
<h3 id="logging-support-for-language-server" data-needslink="logging-support-for-language-server">Logging Support for Language Server</h3>
<p>If you are using <code>vscode-languageclient</code> to implement the client, you can specify a setting <code>[langId].trace.server</code> that instructs the Client to log communications between Language Client / Server to a channel of the Language Client's <code>name</code>.</p>
<p>For <strong>lsp-sample</strong>, you can set this setting: <code>&quot;languageServerExample.trace.server&quot;: &quot;verbose&quot;</code>. Now head to the channel &quot;Language Server Example&quot;. You should see the logs:</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/lsp-log.png" alt="LSP Log"></p>
<p>As Language Servers can be chatty (5 seconds of real-world usage can produce 5000 lines of log), we also provide a tool to visualize and filter the communication between Language Client / Server. You can save all logs from the channel into a file, and load that file with the <a href="https://github.com/Microsoft/language-server-protocol-inspector" class="external-link" target="_blank">Language Server Protocol Inspector</a> at <a href="https://microsoft.github.io/language-server-protocol/inspector" class="external-link" target="_blank">https://microsoft.github.io/language-server-protocol/inspector</a>.</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/lsp-inspector.png" alt="LSP Inspector"></p>
<h3 id="using-configuration-settings-in-the-server" data-needslink="using-configuration-settings-in-the-server">Using Configuration Settings in the Server</h3>
<p>When writing the client part of the extension, we already defined a setting to control the maximum numbers of problems reported. We also wrote code on the server side to read these settings from the client:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">getDocumentSettings</span><span style="color: #000000">(</span><span style="color: #001080">resource</span><span style="color: #000000">: </span><span style="color: #267F99">string</span><span style="color: #000000">): </span><span style="color: #267F99">Thenable</span><span style="color: #000000">&lt;</span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000">&gt; {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (!</span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #267F99">Promise</span><span style="color: #000000">.</span><span style="color: #795E26">resolve</span><span style="color: #000000">(</span><span style="color: #001080">globalSettings</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">result</span><span style="color: #000000"> = </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">get</span><span style="color: #000000">(</span><span style="color: #001080">resource</span><span style="color: #000000">);</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (!</span><span style="color: #001080">result</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #001080">result</span><span style="color: #000000"> = </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #795E26">getConfiguration</span><span style="color: #000000">({</span>
<span style="color: #000000">      </span><span style="color: #001080">scopeUri:</span><span style="color: #000000"> </span><span style="color: #001080">resource</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">section:</span><span style="color: #000000"> </span><span style="color: #A31515">'languageServerExample'</span>
<span style="color: #000000">    });</span>
<span style="color: #000000">    </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">set</span><span style="color: #000000">(</span><span style="color: #001080">resource</span><span style="color: #000000">, </span><span style="color: #001080">result</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">  </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #001080">result</span><span style="color: #000000">;</span>
<span style="color: #000000">}</span></code></pre>
<p>The only thing we need to do now is to listen to configuration changes on the server side and if a settings changes, revalidate the open text documents. To be able to reuse the validate logic of the document change event handling, we extract the code into a <code>validateTextDocument</code> function and modify the code to honor a <code>maxNumberOfProblems</code> variable:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #0000FF">async</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">validateTextDocument</span><span style="color: #000000">(</span><span style="color: #001080">textDocument</span><span style="color: #000000">: </span><span style="color: #267F99">TextDocument</span><span style="color: #000000">): </span><span style="color: #267F99">Promise</span><span style="color: #000000">&lt;</span><span style="color: #267F99">void</span><span style="color: #000000">&gt; {</span>
<span style="color: #000000">  </span><span style="color: #008000">// In this simple example we get the settings for every validate run.</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">settings</span><span style="color: #000000"> = </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #795E26">getDocumentSettings</span><span style="color: #000000">(</span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">);</span>

<span style="color: #000000">  </span><span style="color: #008000">// The validator creates diagnostics for all uppercase words length 2 and more</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">text</span><span style="color: #000000"> = </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">getText</span><span style="color: #000000">();</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">pattern</span><span style="color: #000000"> =</span><span style="color: #A31515"> /</span><span style="color: #FF0000">\b</span><span style="color: #D16969">[</span><span style="color: #811F3F">A-Z</span><span style="color: #D16969">]</span><span style="color: #000000">{2,}</span><span style="color: #FF0000">\b</span><span style="color: #A31515">/</span><span style="color: #0000FF">g</span><span style="color: #000000">;</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">m</span><span style="color: #000000">: </span><span style="color: #267F99">RegExpExecArray</span><span style="color: #000000">;</span>

<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">problems</span><span style="color: #000000"> = </span><span style="color: #098658">0</span><span style="color: #000000">;</span>
<span style="color: #000000">  </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">diagnostics</span><span style="color: #000000">: </span><span style="color: #267F99">Diagnostic</span><span style="color: #000000">[] = [];</span>
<span style="color: #000000">  </span><span style="color: #0000FF">while</span><span style="color: #000000"> ((</span><span style="color: #001080">m</span><span style="color: #000000"> = </span><span style="color: #001080">pattern</span><span style="color: #000000">.</span><span style="color: #795E26">exec</span><span style="color: #000000">(</span><span style="color: #001080">text</span><span style="color: #000000">)) && </span><span style="color: #001080">problems</span><span style="color: #000000"> &lt; </span><span style="color: #001080">settings</span><span style="color: #000000">.</span><span style="color: #001080">maxNumberOfProblems</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #001080">problems</span><span style="color: #000000">++;</span>
<span style="color: #000000">    </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">diagnostic</span><span style="color: #000000">: </span><span style="color: #267F99">Diagnostic</span><span style="color: #000000"> = {</span>
<span style="color: #000000">      </span><span style="color: #001080">severity:</span><span style="color: #000000"> </span><span style="color: #001080">DiagnosticSeverity</span><span style="color: #000000">.</span><span style="color: #001080">Warning</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">range:</span><span style="color: #000000"> {</span>
<span style="color: #000000">        </span><span style="color: #001080">start:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">positionAt</span><span style="color: #000000">(</span><span style="color: #001080">m</span><span style="color: #000000">.</span><span style="color: #001080">index</span><span style="color: #000000">),</span>
<span style="color: #000000">        </span><span style="color: #001080">end:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #795E26">positionAt</span><span style="color: #000000">(</span><span style="color: #001080">m</span><span style="color: #000000">.</span><span style="color: #001080">index</span><span style="color: #000000"> + </span><span style="color: #001080">m</span><span style="color: #000000">[</span><span style="color: #098658">0</span><span style="color: #000000">].</span><span style="color: #001080">length</span><span style="color: #000000">)</span>
<span style="color: #000000">      },</span>
<span style="color: #000000">      </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">`</span><span style="color: #0000FF">${</span><span style="color: #001080">m</span><span style="color: #000000">[</span><span style="color: #098658">0</span><span style="color: #000000">]</span><span style="color: #0000FF">}</span><span style="color: #A31515"> is all uppercase.`</span><span style="color: #000000">,</span>
<span style="color: #000000">      </span><span style="color: #001080">source:</span><span style="color: #000000"> </span><span style="color: #A31515">'ex'</span>
<span style="color: #000000">    };</span>
<span style="color: #000000">    </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasDiagnosticRelatedInformationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">      </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">relatedInformation</span><span style="color: #000000"> = [</span>
<span style="color: #000000">        {</span>
<span style="color: #000000">          </span><span style="color: #001080">location:</span><span style="color: #000000"> {</span>
<span style="color: #000000">            </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #001080">range:</span><span style="color: #000000"> </span><span style="color: #267F99">Object</span><span style="color: #000000">.</span><span style="color: #795E26">assign</span><span style="color: #000000">({}, </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">range</span><span style="color: #000000">)</span>
<span style="color: #000000">          },</span>
<span style="color: #000000">          </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">'Spelling matters'</span>
<span style="color: #000000">        },</span>
<span style="color: #000000">        {</span>
<span style="color: #000000">          </span><span style="color: #001080">location:</span><span style="color: #000000"> {</span>
<span style="color: #000000">            </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">,</span>
<span style="color: #000000">            </span><span style="color: #001080">range:</span><span style="color: #000000"> </span><span style="color: #267F99">Object</span><span style="color: #000000">.</span><span style="color: #795E26">assign</span><span style="color: #000000">({}, </span><span style="color: #001080">diagnostic</span><span style="color: #000000">.</span><span style="color: #001080">range</span><span style="color: #000000">)</span>
<span style="color: #000000">          },</span>
<span style="color: #000000">          </span><span style="color: #001080">message:</span><span style="color: #000000"> </span><span style="color: #A31515">'Particularly for names'</span>
<span style="color: #000000">        }</span>
<span style="color: #000000">      ];</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">    </span><span style="color: #001080">diagnostics</span><span style="color: #000000">.</span><span style="color: #795E26">push</span><span style="color: #000000">(</span><span style="color: #001080">diagnostic</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>

<span style="color: #000000">  </span><span style="color: #008000">// Send the computed diagnostics to VS Code.</span>
<span style="color: #000000">  </span><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">sendDiagnostics</span><span style="color: #000000">({ </span><span style="color: #001080">uri:</span><span style="color: #000000"> </span><span style="color: #001080">textDocument</span><span style="color: #000000">.</span><span style="color: #001080">uri</span><span style="color: #000000">, </span><span style="color: #001080">diagnostics</span><span style="color: #000000"> });</span>
<span style="color: #000000">}</span></code></pre>
<p>The handling of the configuration change is done by adding a notification handler for configuration changes to the connection. The corresponding code looks like this:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeConfiguration</span><span style="color: #000000">(</span><span style="color: #001080">change</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">hasConfigurationCapability</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #008000">// Reset all cached document settings</span>
<span style="color: #000000">    </span><span style="color: #001080">documentSettings</span><span style="color: #000000">.</span><span style="color: #795E26">clear</span><span style="color: #000000">();</span>
<span style="color: #000000">  } </span><span style="color: #0000FF">else</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #001080">globalSettings</span><span style="color: #000000"> = &lt;</span><span style="color: #267F99">ExampleSettings</span><span style="color: #000000">&gt;(</span>
<span style="color: #000000">      (</span><span style="color: #001080">change</span><span style="color: #000000">.</span><span style="color: #001080">settings</span><span style="color: #000000">.</span><span style="color: #001080">languageServerExample</span><span style="color: #000000"> || </span><span style="color: #001080">defaultSettings</span><span style="color: #000000">)</span>
<span style="color: #000000">    );</span>
<span style="color: #000000">  }</span>

<span style="color: #000000">  </span><span style="color: #008000">// Revalidate all open text documents</span>
<span style="color: #000000">  </span><span style="color: #001080">documents</span><span style="color: #000000">.</span><span style="color: #795E26">all</span><span style="color: #000000">().</span><span style="color: #795E26">forEach</span><span style="color: #000000">(</span><span style="color: #001080">validateTextDocument</span><span style="color: #000000">);</span>
<span style="color: #000000">});</span></code></pre>
<p>Starting the client again and changing the setting to maximum report 1 problem results in the following validation:</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/validationOneProblem.png" alt="Maximum One Problem"></p>
<h3 id="adding-additional-language-features" data-needslink="adding-additional-language-features">Adding additional Language Features</h3>
<p>The first interesting feature a language server usually implements is validation of documents. In that sense, even a linter counts as a language server and in VS Code linters are usually implemented as language servers (see <a href="https://github.com/Microsoft/vscode-eslint" class="external-link" target="_blank">eslint</a> and <a href="https://github.com/Microsoft/vscode-jshint" class="external-link" target="_blank">jshint</a> for examples). But there is more to language servers. They can provide code completion, Find All References, or Go To Definition. The example code below adds code completion to the server. It proposes the two words 'TypeScript' and 'JavaScript'.</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #008000">// This handler provides the initial list of the completion items.</span>
<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onCompletion</span><span style="color: #000000">(</span>
<span style="color: #000000">  (</span><span style="color: #001080">_textDocumentPosition</span><span style="color: #000000">: </span><span style="color: #267F99">TextDocumentPositionParams</span><span style="color: #000000">): </span><span style="color: #267F99">CompletionItem</span><span style="color: #000000">[] </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #008000">// The pass parameter contains the position of the text document in</span>
<span style="color: #000000">    </span><span style="color: #008000">// which code complete got requested. For the example we ignore this</span>
<span style="color: #000000">    </span><span style="color: #008000">// info and always provide the same completion items.</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> [</span>
<span style="color: #000000">      {</span>
<span style="color: #000000">        </span><span style="color: #001080">label:</span><span style="color: #000000"> </span><span style="color: #A31515">'TypeScript'</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">kind:</span><span style="color: #000000"> </span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">.</span><span style="color: #001080">Text</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">data:</span><span style="color: #000000"> </span><span style="color: #098658">1</span>
<span style="color: #000000">      },</span>
<span style="color: #000000">      {</span>
<span style="color: #000000">        </span><span style="color: #001080">label:</span><span style="color: #000000"> </span><span style="color: #A31515">'JavaScript'</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">kind:</span><span style="color: #000000"> </span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">.</span><span style="color: #001080">Text</span><span style="color: #000000">,</span>
<span style="color: #000000">        </span><span style="color: #001080">data:</span><span style="color: #000000"> </span><span style="color: #098658">2</span>
<span style="color: #000000">      }</span>
<span style="color: #000000">    ];</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">);</span>

<span style="color: #008000">// This handler resolves additional information for the item selected in</span>
<span style="color: #008000">// the completion list.</span>
<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onCompletionResolve</span><span style="color: #000000">(</span>
<span style="color: #000000">  (</span><span style="color: #001080">item</span><span style="color: #000000">: </span><span style="color: #267F99">CompletionItem</span><span style="color: #000000">): </span><span style="color: #267F99">CompletionItem</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">data</span><span style="color: #000000"> === </span><span style="color: #098658">1</span><span style="color: #000000">) {</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">detail</span><span style="color: #000000"> = </span><span style="color: #A31515">'TypeScript details'</span><span style="color: #000000">;</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">documentation</span><span style="color: #000000"> = </span><span style="color: #A31515">'TypeScript documentation'</span><span style="color: #000000">;</span>
<span style="color: #000000">    } </span><span style="color: #0000FF">else</span><span style="color: #000000"> </span><span style="color: #0000FF">if</span><span style="color: #000000"> (</span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">data</span><span style="color: #000000"> === </span><span style="color: #098658">2</span><span style="color: #000000">) {</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">detail</span><span style="color: #000000"> = </span><span style="color: #A31515">'JavaScript details'</span><span style="color: #000000">;</span>
<span style="color: #000000">      </span><span style="color: #001080">item</span><span style="color: #000000">.</span><span style="color: #001080">documentation</span><span style="color: #000000"> = </span><span style="color: #A31515">'JavaScript documentation'</span><span style="color: #000000">;</span>
<span style="color: #000000">    }</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #001080">item</span><span style="color: #000000">;</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">);</span></code></pre>
<p>The <code>data</code> fields are used to uniquely identify a completion item in the resolve handler. The data property is transparent for the protocol. Since the underlying message passing protocol is JSON-based, the data field should only hold data that is serializable to and from JSON.</p>
<p>All that is missing is to tell VS Code that the server supports code completion requests. To do so, flag the corresponding capability in the initialize handler:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onInitialize</span><span style="color: #000000">((</span><span style="color: #001080">params</span><span style="color: #000000">): </span><span style="color: #267F99">InitializeResult</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    ...</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> {</span>
<span style="color: #000000">        </span><span style="color: #001080">capabilities:</span><span style="color: #000000"> {</span>
<span style="color: #000000">            ...</span>
<span style="color: #000000">            </span><span style="color: #008000">// Tell the client that the server supports code completion</span>
<span style="color: #000000">            </span><span style="color: #001080">completionProvider</span><span style="color: #000000">: {</span>
<span style="color: #000000">                </span><span style="color: #001080">resolveProvider:</span><span style="color: #000000"> </span><span style="color: #0000FF">true</span>
<span style="color: #000000">            }</span>
<span style="color: #000000">        }</span>
<span style="color: #000000">    };</span>
<span style="color: #000000">});</span></code></pre>
<p>The screenshot below shows the completed code running on a plain text file:</p>
<p><img src="/assets/api/language-extensions/language-server-extension-guide/codeComplete.png" alt="Code Complete"></p>
<h3 id="testing-the-language-server" data-needslink="testing-the-language-server">Testing The Language Server</h3>
<p>To create a high-quality Language Server, we need to build a good test suite covering its functionalities. There are two common ways of testing Language Servers:</p>
<ul>
<li>Unit Test: This is useful if you want to test specific functionalities in Language Servers by mocking up all the information being sent to it. VS Code's <a href="https://github.com/Microsoft/vscode-html-languageservice" class="external-link" target="_blank">HTML</a> / <a href="https://github.com/Microsoft/vscode-css-languageservice" class="external-link" target="_blank">CSS</a> / <a href="https://github.com/Microsoft/vscode-json-languageservice" class="external-link" target="_blank">JSON</a> Language Servers take this approach to testing. The LSP npm modules itself use the approach. See <a href="https://github.com/Microsoft/vscode-languageserver-node/blob/master/protocol/src/test/connection.test.ts" class="external-link" target="_blank">here</a> for some unit test written using the npm protocol module.</li>
<li>End-to-End Test: This is similar to <a href="/api/working-with-extensions/testing-extension">VS Code extension test</a>. The benefit of this approach is that it runs the test by instantiating a VS Code instance with a workspace, opening the file, activating the Language Client / Server, and running <a href="/api/references/commands">VS Code commands</a>. This approach is superior if you have files, settings, or dependencies (such as <code>node_modules</code>) which are hard or impossible to mock. The popular <a href="https://github.com/Microsoft/vscode-python" class="external-link" target="_blank">Python</a> extension takes this approach to testing.</li>
</ul>
<p>It is possible to do Unit Test in any testing framework of your choice. Here we describe how to do End-to-End testing for Language Server Extension.</p>
<p>Open <code>.vscode/launch.json</code>, and you can find a <code>E2E</code> test target:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #000000">{</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"name"</span><span style="color: #000000">: </span><span style="color: #A31515">"Language Server E2E Test"</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"type"</span><span style="color: #000000">: </span><span style="color: #A31515">"extensionHost"</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"request"</span><span style="color: #000000">: </span><span style="color: #A31515">"launch"</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"runtimeExecutable"</span><span style="color: #000000">: </span><span style="color: #A31515">"${execPath}"</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"args"</span><span style="color: #000000">: [</span>
<span style="color: #000000">    </span><span style="color: #A31515">"--extensionDevelopmentPath=${workspaceRoot}"</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #A31515">"--extensionTestsPath=${workspaceRoot}/client/out/test"</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #A31515">"${workspaceRoot}/client/testFixture"</span>
<span style="color: #000000">  ],</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"stopOnEntry"</span><span style="color: #000000">: </span><span style="color: #0000FF">false</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"sourceMaps"</span><span style="color: #000000">: </span><span style="color: #0000FF">true</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #0451A5">"outFiles"</span><span style="color: #000000">: [</span><span style="color: #A31515">"${workspaceRoot}/client/out/test/**/*.js"</span><span style="color: #000000">]</span>
<span style="color: #000000">}</span></code></pre>
<p>If you run this debug target, it will launch a VS Code instance with <code>client/testFixture</code> as the active workspace. VS Code will then proceed to execute all tests in <code>client/src/test</code>. As a debugging tip, you can set breakpoints in TypeScript files in <code>client/src/test</code> and they will be hit.</p>
<p>Let's take a look at the <code>completion.test.ts</code> file:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #0000FF">import</span><span style="color: #000000"> </span><span style="color: #0000FF">*</span><span style="color: #000000"> </span><span style="color: #0000FF">as</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000"> </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'vscode'</span><span style="color: #000000">;</span>
<span style="color: #0000FF">import</span><span style="color: #000000"> </span><span style="color: #0000FF">*</span><span style="color: #000000"> </span><span style="color: #0000FF">as</span><span style="color: #000000"> </span><span style="color: #001080">assert</span><span style="color: #000000"> </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'assert'</span><span style="color: #000000">;</span>
<span style="color: #0000FF">import</span><span style="color: #000000"> { </span><span style="color: #001080">getDocUri</span><span style="color: #000000">, </span><span style="color: #001080">activate</span><span style="color: #000000"> } </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'./helper'</span><span style="color: #000000">;</span>

<span style="color: #795E26">describe</span><span style="color: #000000">(</span><span style="color: #A31515">'Should do completion'</span><span style="color: #000000">, () </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">const</span><span style="color: #000000"> </span><span style="color: #001080">docUri</span><span style="color: #000000"> = </span><span style="color: #795E26">getDocUri</span><span style="color: #000000">(</span><span style="color: #A31515">'completion.txt'</span><span style="color: #000000">);</span>

<span style="color: #000000">  </span><span style="color: #795E26">it</span><span style="color: #000000">(</span><span style="color: #A31515">'Completes JS/TS in txt file'</span><span style="color: #000000">, </span><span style="color: #0000FF">async</span><span style="color: #000000"> () </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #795E26">testCompletion</span><span style="color: #000000">(</span><span style="color: #001080">docUri</span><span style="color: #000000">, </span><span style="color: #0000FF">new</span><span style="color: #000000"> </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">Position</span><span style="color: #000000">(</span><span style="color: #098658">0</span><span style="color: #000000">, </span><span style="color: #098658">0</span><span style="color: #000000">), {</span>
<span style="color: #000000">      </span><span style="color: #001080">items:</span><span style="color: #000000"> [</span>
<span style="color: #000000">        { </span><span style="color: #001080">label:</span><span style="color: #000000"> </span><span style="color: #A31515">'JavaScript'</span><span style="color: #000000">, </span><span style="color: #001080">kind:</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000">.</span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">.</span><span style="color: #001080">Text</span><span style="color: #000000"> },</span>
<span style="color: #000000">        { </span><span style="color: #001080">label:</span><span style="color: #000000"> </span><span style="color: #A31515">'TypeScript'</span><span style="color: #000000">, </span><span style="color: #001080">kind:</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000">.</span><span style="color: #001080">CompletionItemKind</span><span style="color: #000000">.</span><span style="color: #001080">Text</span><span style="color: #000000"> }</span>
<span style="color: #000000">      ]</span>
<span style="color: #000000">    });</span>
<span style="color: #000000">  });</span>
<span style="color: #000000">});</span>

<span style="color: #0000FF">async</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">testCompletion</span><span style="color: #000000">(</span>
<span style="color: #000000">  </span><span style="color: #001080">docUri</span><span style="color: #000000">: </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">Uri</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">position</span><span style="color: #000000">: </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">Position</span><span style="color: #000000">,</span>
<span style="color: #000000">  </span><span style="color: #001080">expectedCompletionList</span><span style="color: #000000">: </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">CompletionList</span>
<span style="color: #000000">) {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #795E26">activate</span><span style="color: #000000">(</span><span style="color: #001080">docUri</span><span style="color: #000000">);</span>

<span style="color: #000000">  </span><span style="color: #008000">// Executing the command `vscode.executeCompletionItemProvider` to simulate triggering completion</span>
<span style="color: #000000">  </span><span style="color: #0000FF">const</span><span style="color: #000000"> </span><span style="color: #001080">actualCompletionList</span><span style="color: #000000"> = (</span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000">.</span><span style="color: #001080">commands</span><span style="color: #000000">.</span><span style="color: #795E26">executeCommand</span><span style="color: #000000">(</span>
<span style="color: #000000">    </span><span style="color: #A31515">'vscode.executeCompletionItemProvider'</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #001080">docUri</span><span style="color: #000000">,</span>
<span style="color: #000000">    </span><span style="color: #001080">position</span>
<span style="color: #000000">  )) </span><span style="color: #0000FF">as</span><span style="color: #000000"> </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">CompletionList</span><span style="color: #000000">;</span>

<span style="color: #000000">  assert.</span><span style="color: #795E26">equal</span><span style="color: #000000">(</span><span style="color: #001080">actualCompletionList</span><span style="color: #000000">.</span><span style="color: #001080">items</span><span style="color: #000000">.</span><span style="color: #001080">length</span><span style="color: #000000">, </span><span style="color: #001080">expectedCompletionList</span><span style="color: #000000">.</span><span style="color: #001080">items</span><span style="color: #000000">.</span><span style="color: #001080">length</span><span style="color: #000000">);</span>
<span style="color: #000000">  </span><span style="color: #001080">expectedCompletionList</span><span style="color: #000000">.</span><span style="color: #001080">items</span><span style="color: #000000">.</span><span style="color: #795E26">forEach</span><span style="color: #000000">((</span><span style="color: #001080">expectedItem</span><span style="color: #000000">, </span><span style="color: #001080">i</span><span style="color: #000000">) </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #0000FF">const</span><span style="color: #000000"> </span><span style="color: #001080">actualItem</span><span style="color: #000000"> = </span><span style="color: #001080">actualCompletionList</span><span style="color: #000000">.</span><span style="color: #001080">items</span><span style="color: #000000">[</span><span style="color: #001080">i</span><span style="color: #000000">];</span>
<span style="color: #000000">    assert.</span><span style="color: #795E26">equal</span><span style="color: #000000">(</span><span style="color: #001080">actualItem</span><span style="color: #000000">.</span><span style="color: #001080">label</span><span style="color: #000000">, </span><span style="color: #001080">expectedItem</span><span style="color: #000000">.</span><span style="color: #001080">label</span><span style="color: #000000">);</span>
<span style="color: #000000">    assert.</span><span style="color: #795E26">equal</span><span style="color: #000000">(</span><span style="color: #001080">actualItem</span><span style="color: #000000">.</span><span style="color: #001080">kind</span><span style="color: #000000">, </span><span style="color: #001080">expectedItem</span><span style="color: #000000">.</span><span style="color: #001080">kind</span><span style="color: #000000">);</span>
<span style="color: #000000">  });</span>
<span style="color: #000000">}</span></code></pre>
<p>In this test, we:</p>
<ul>
<li>Activate the extension.</li>
<li>Run the command <code>vscode.executeCompletionItemProvider</code> with a URI and a position to simulate completion trigger.</li>
<li>Assert the returned completion items against our expected completion items.</li>
</ul>
<p>Let's dive a bit deeper into the <code>activate(docURI)</code> function. It is defined in <code>client/src/test/helper.ts</code>:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #0000FF">import</span><span style="color: #000000"> </span><span style="color: #0000FF">*</span><span style="color: #000000"> </span><span style="color: #0000FF">as</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000"> </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'vscode'</span><span style="color: #000000">;</span>
<span style="color: #0000FF">import</span><span style="color: #000000"> </span><span style="color: #0000FF">*</span><span style="color: #000000"> </span><span style="color: #0000FF">as</span><span style="color: #000000"> </span><span style="color: #001080">path</span><span style="color: #000000"> </span><span style="color: #0000FF">from</span><span style="color: #000000"> </span><span style="color: #A31515">'path'</span><span style="color: #000000">;</span>

<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">doc</span><span style="color: #000000">: </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">TextDocument</span><span style="color: #000000">;</span>
<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">editor</span><span style="color: #000000">: </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">TextEditor</span><span style="color: #000000">;</span>
<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">documentEol</span><span style="color: #000000">: </span><span style="color: #267F99">string</span><span style="color: #000000">;</span>
<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">let</span><span style="color: #000000"> </span><span style="color: #001080">platformEol</span><span style="color: #000000">: </span><span style="color: #267F99">string</span><span style="color: #000000">;</span>

<span style="color: #008000">/**</span>
<span style="color: #008000"> * Activates the vscode.lsp-sample extension</span>
<span style="color: #008000"> */</span>
<span style="color: #0000FF">export</span><span style="color: #000000"> </span><span style="color: #0000FF">async</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">activate</span><span style="color: #000000">(</span><span style="color: #001080">docUri</span><span style="color: #000000">: </span><span style="color: #267F99">vscode</span><span style="color: #000000">.</span><span style="color: #267F99">Uri</span><span style="color: #000000">) {</span>
<span style="color: #000000">  </span><span style="color: #008000">// The extensionId is `publisher.name` from package.json</span>
<span style="color: #000000">  </span><span style="color: #0000FF">const</span><span style="color: #000000"> </span><span style="color: #001080">ext</span><span style="color: #000000"> = </span><span style="color: #001080">vscode</span><span style="color: #000000">.</span><span style="color: #001080">extensions</span><span style="color: #000000">.</span><span style="color: #795E26">getExtension</span><span style="color: #000000">(</span><span style="color: #A31515">'vscode.lsp-sample'</span><span style="color: #000000">);</span>
<span style="color: #000000">  </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #001080">ext</span><span style="color: #000000">.</span><span style="color: #795E26">activate</span><span style="color: #000000">();</span>
<span style="color: #000000">  </span><span style="color: #0000FF">try</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #001080">doc</span><span style="color: #000000"> = </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000">.</span><span style="color: #001080">workspace</span><span style="color: #000000">.</span><span style="color: #795E26">openTextDocument</span><span style="color: #000000">(</span><span style="color: #001080">docUri</span><span style="color: #000000">);</span>
<span style="color: #000000">    </span><span style="color: #001080">editor</span><span style="color: #000000"> = </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #001080">vscode</span><span style="color: #000000">.</span><span style="color: #001080">window</span><span style="color: #000000">.</span><span style="color: #795E26">showTextDocument</span><span style="color: #000000">(</span><span style="color: #001080">doc</span><span style="color: #000000">);</span>
<span style="color: #000000">    </span><span style="color: #0000FF">await</span><span style="color: #000000"> </span><span style="color: #795E26">sleep</span><span style="color: #000000">(</span><span style="color: #098658">2000</span><span style="color: #000000">); </span><span style="color: #008000">// Wait for server activation</span>
<span style="color: #000000">  } </span><span style="color: #0000FF">catch</span><span style="color: #000000"> (</span><span style="color: #001080">e</span><span style="color: #000000">) {</span>
<span style="color: #000000">    </span><span style="color: #267F99">console</span><span style="color: #000000">.</span><span style="color: #795E26">error</span><span style="color: #000000">(</span><span style="color: #001080">e</span><span style="color: #000000">);</span>
<span style="color: #000000">  }</span>
<span style="color: #000000">}</span>

<span style="color: #0000FF">async</span><span style="color: #000000"> </span><span style="color: #0000FF">function</span><span style="color: #000000"> </span><span style="color: #795E26">sleep</span><span style="color: #000000">(</span><span style="color: #001080">ms</span><span style="color: #000000">: </span><span style="color: #267F99">number</span><span style="color: #000000">) {</span>
<span style="color: #000000">  </span><span style="color: #0000FF">return</span><span style="color: #000000"> </span><span style="color: #0000FF">new</span><span style="color: #000000"> </span><span style="color: #267F99">Promise</span><span style="color: #000000">(</span><span style="color: #001080">resolve</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> </span><span style="color: #795E26">setTimeout</span><span style="color: #000000">(</span><span style="color: #001080">resolve</span><span style="color: #000000">, </span><span style="color: #001080">ms</span><span style="color: #000000">));</span>
<span style="color: #000000">}</span></code></pre>
<p>In the activation part, we:</p>
<ul>
<li>Get the extension using the <code>{publisher.name}.{extensionId}</code>, as defined in <code>package.json</code>.</li>
<li>Open the specified document, and show it in the active text editor.</li>
<li>Sleep for 2 seconds, so we are sure the Language Server is instantiated.</li>
</ul>
<p>After the preparation, we can run the <a href="/api/references/commands">VS Code Commands</a> corresponding to each language feature, and assert against the returned result.</p>
<p>There is one more test that covers the diagnostics feature that we just implemented. Check it out at <code>client/src/test/diagnostics.test.ts</code>.</p>
<h2 id="advanced-topics" data-needslink="advanced-topics">Advanced Topics</h2>
<p>So far, this guide covered:</p>
<ul>
<li>A brief overview of Language Server and Language Server Protocol.</li>
<li>Architecture of a Language Server extension in VS Code</li>
<li>The <strong>lsp-sample</strong> extension, and how to develop/debug/inspect/test it.</li>
</ul>
<p>There are some more advanced topics we could not fit in to this guide. We will include links to these resources for further studying of Language Server development.</p>
<h3 id="additional-language-server-features" data-needslink="additional-language-server-features">Additional Language Server features</h3>
<p>The following language features are currently supported in a language server along with code completions:</p>
<ul>
<li><em>Document Highlights</em>: highlights all 'equal' symbols in a text document.</li>
<li><em>Hover</em>: provides hover information for a symbol selected in a text document.</li>
<li><em>Signature Help</em>: provides signature help for a symbol selected in a text document.</li>
<li><em>Goto Definition</em>: provides go to definition support for a symbol selected in a text document.</li>
<li><em>Goto Type Definition</em>: provides go to type/interface definition support for a symbol selected in a text document.</li>
<li><em>Goto Implementation</em>: provides go to implementation definition support for a symbol selected in a text document.</li>
<li><em>Find References</em>: finds all project-wide references for a symbol selected in a text document.</li>
<li><em>List Document Symbols</em>: lists all symbols defined in a text document.</li>
<li><em>List Workspace Symbols</em>: lists all project-wide symbols.</li>
<li><em>Code Actions</em>: compute commands to run (typically beautify/refactor) for a given text document and range.</li>
<li><em>CodeLens</em>: compute CodeLens statistics for a given text document.</li>
<li><em>Document Formatting</em>: this includes formatting of whole documents, document ranges and formatting on type.</li>
<li><em>Rename</em>: project-wide rename of a symbol.</li>
<li><em>Document Links</em>: compute and resolve links inside a document.</li>
<li><em>Document Colors</em>: compute and resolve colors inside a document to provide color picker in editor.</li>
</ul>
<p>The <a href="/api/language-extensions/programmatic-language-features">Programmatic Language Features</a> topic describes each of the language features above and provides guidance on how to implement them either through the language server protocol or by using the extensibility API directly from your extension.</p>
<h3 id="incremental-text-document-synchronization" data-needslink="incremental-text-document-synchronization">Incremental Text Document Synchronization</h3>
<p>The example uses the simple text document manager provided by the <code>vscode-languageserver</code> module to synchronize documents between VS Code and the language server.</p>
<p>This has two drawbacks:</p>
<ul>
<li>Lots of data transfer since the whole content of a text document is sent to the server repeatedly.</li>
<li>If an existing language library is used, such libraries usually support incremental document updates to avoid unnecessary parsing and abstract syntax tree creation.</li>
</ul>
<p>The protocol therefore supports incremental document synchronization as well.</p>
<p>To make use of incremental document synchronization, a server needs to install three notification handlers:</p>
<ul>
<li><em>onDidOpenTextDocument</em>: is called when a text document is opened in VS Code.</li>
<li><em>onDidChangeTextDocument</em>: is called when the content of a text document changes in VS Code.</li>
<li><em>onDidCloseTextDocument</em>: is called when a text document is closed in VS Code.</li>
</ul>
<p>Below is a code snippet that illustrates how to hook these notification handlers on a connection and how to return the right capability on initialize:</p>
<pre class="shiki" style="background-color: #FFFFFF"><code><span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onInitialize</span><span style="color: #000000">((</span><span style="color: #001080">params</span><span style="color: #000000">): </span><span style="color: #267F99">InitializeResult</span><span style="color: #000000"> </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    ...</span>
<span style="color: #000000">    </span><span style="color: #0000FF">return</span><span style="color: #000000"> {</span>
<span style="color: #000000">        </span><span style="color: #001080">capabilities:</span><span style="color: #000000"> {</span>
<span style="color: #000000">            </span><span style="color: #008000">// Enable incremental document sync</span>
<span style="color: #000000">            </span><span style="color: #001080">textDocumentSync:</span><span style="color: #000000"> </span><span style="color: #001080">TextDocumentSyncKind</span><span style="color: #000000">.</span><span style="color: #001080">Incremental</span><span style="color: #000000">,</span>
<span style="color: #000000">            ...</span>
<span style="color: #000000">        }</span>
<span style="color: #000000">    };</span>
<span style="color: #000000">});</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onDidOpenTextDocument</span><span style="color: #000000">((</span><span style="color: #001080">params</span><span style="color: #000000">) </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #008000">// A text document was opened in VS Code.</span>
<span style="color: #000000">    </span><span style="color: #008000">// params.uri uniquely identifies the document. For documents stored on disk, this is a file URI.</span>
<span style="color: #000000">    </span><span style="color: #008000">// params.text the initial full content of the document.</span>
<span style="color: #000000">});</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onDidChangeTextDocument</span><span style="color: #000000">((</span><span style="color: #001080">params</span><span style="color: #000000">) </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #008000">// The content of a text document has change in VS Code.</span>
<span style="color: #000000">    </span><span style="color: #008000">// params.uri uniquely identifies the document.</span>
<span style="color: #000000">    </span><span style="color: #008000">// params.contentChanges describe the content changes to the document.</span>
<span style="color: #000000">});</span>

<span style="color: #001080">connection</span><span style="color: #000000">.</span><span style="color: #795E26">onDidCloseTextDocument</span><span style="color: #000000">((</span><span style="color: #001080">params</span><span style="color: #000000">) </span><span style="color: #0000FF">=&gt;</span><span style="color: #000000"> {</span>
<span style="color: #000000">    </span><span style="color: #008000">// A text document was closed in VS Code.</span>
<span style="color: #000000">    </span><span style="color: #008000">// params.uri uniquely identifies the document.</span>
<span style="color: #000000">});</span></code></pre>
<h3 id="using-vs-code-api-directly-to-implement-language-features" data-needslink="using-vs-code-api-directly-to-implement-language-features">Using VS Code API directly to implement Language Features</h3>
<p>While Language Servers have many benefits, they are not the only option for extending the editing capabilities of VS Code. In the cases when you want to add some simple language features for a type of document, consider using <code>vscode.languages.register[LANGUAGE_FEATURE]Provider</code> as an option.</p>
<p>Here is a <a href="https://github.com/Microsoft/vscode-extension-samples/tree/master/completions-sample" class="external-link" target="_blank"><code>completions-sample</code></a> using <code>vscode.languages.registerCompletionItemProvider</code> to add a few snippets as completions for plain text files.</p>
<p>More samples illustrating the usage of VS Code API can be found at <a href="https://github.com/Microsoft/vscode-extension-samples" class="external-link" target="_blank">https://github.com/Microsoft/vscode-extension-samples</a>.</p>
<h3 id="error-tolerant-parser-for-language-server" data-needslink="error-tolerant-parser-for-language-server">Error Tolerant Parser for Language Server</h3>
<p>Most of the time, the code in the editor is incomplete and syntactically incorrect, but developers would still expect autocomplete and other language features to work. Therefore, an error tolerant parser is necessary for a Language Server: The parser generates meaningful AST from partially complete code, and the Language Server provides language features based on the AST.</p>
<p>When we were improving PHP support in VS Code, we realized the official PHP parser is not error tolerant and cannot be reused directly in the Language Server. Therefore, we worked on <a href="https://github.com/Microsoft/tolerant-php-parser" class="external-link" target="_blank">Microsoft/tolerant-php-parser</a> and left detailed <a href="https://github.com/Microsoft/tolerant-php-parser/blob/master/docs/HowItWorks.md" class="external-link" target="_blank">notes</a> that might help Language Server authors who need to implement an error tolerant parser.</p>
<h2 id="common-questions" data-needslink="common-questions">Common questions</h2>
<h3 id="when-i-try-to-attach-to-the-server-i-get-cannot-connect-to-runtime-process-timeout-after-5000-ms" data-needslink="when-i-try-to-attach-to-the-server-i-get-cannot-connect-to-runtime-process-timeout-after-5000-ms">When I try to attach to the server, I get &quot;cannot connect to runtime process (timeout after 5000 ms)&quot;?</h3>
<p>You will see this timeout error if the server isn't running when you try to attach the debugger. The client starts the language server so make sure you have started the client in order to have a running server. You may also need to disable your client breakpoints if they are interfering with starting the server.</p>
<h3 id="i-have-read-through-this-guide-and-the-lsp-specificationhttpsmicrosoft.github.iolanguageserverprotocol-but-i-still-have-unresolved-questions.-where-can-i-get-help" data-needslink="i-have-read-through-this-guide-and-the-lsp-specificationhttpsmicrosoft.github.iolanguageserverprotocol-but-i-still-have-unresolved-questions.-where-can-i-get-help">I have read through this guide and the <a href="https://microsoft.github.io/language-server-protocol/" class="external-link" target="_blank">LSP Specification</a>, but I still have unresolved questions. Where can I get help?</h3>
<p>Please open an issue at <a href="https://github.com/Microsoft/language-server-protocol" class="external-link" target="_blank">https://github.com/Microsoft/language-server-protocol</a>.</p>

			<div class="feedback"></div>
			
			<div class="body-footer">5/7/2020</div>
			
		</div>
        <div class="col-sm-3 col-md-2 docs-subnavbar-container">
            <nav id="docs-subnavbar" aria-label="On Page" data-spy="affix" data-offset-top="20">
				<h4 tabIndex="0"><span class="sr-only">In this article there are 4 sections</span><span aria-hidden="true">In this article</span></h4>
                <ul class="nav">
                	
                		<li><a href="#why-language-server">Why Language Server?</a></li>
                	
                		<li><a href="#implementing-a-language-server">Implementing a Language Server</a></li>
                	
                		<li><a href="#advanced-topics">Advanced Topics</a></li>
                	
                		<li><a href="#common-questions">Common questions</a></li>
                	
				</ul>
				<div class="connect-widget"></div>
			</nav>
        </div>
	</div>
</div>
      </div>
  </div>

  <footer role="contentinfo">
      <div class="container">
          <div class="row">
              <div class="left col-md-7">
                  <ul class="links">
                      <li>
                          <span class="message">Hello from Seattle.</span>
                      </li>
                      <li>
                          <a href="https://go.microsoft.com/fwlink/?LinkID=533687" onclick="followOnTwitter()" role="button" tabindex="0">Follow @code</a>
                      </li>
                      <li>
                          <div class="github-star-button">
                              <iframe src="/assets/github-button.html?user=Microsoft&repo=vscode&type=star&count=true"
                                  frameborder="0" scrolling="0" width="130px" height="20px" title="GitHub follow button" aria-label="GitHub follow button"></iframe>
                          </div>
                      </li>
  
                      <script>
                          function followOnTwitter() {
                              var windowFeatures = "location=yes,height=600,width=550,scrollbars=yes,status=yes";
                              var originalReferer = "&original_referer=" + document.URL;
                              var screenName = "&screen_name=code";
                              var URL = "https://twitter.com/intent/follow?" + originalReferer + screenName;
                              window.open(URL, "_blank", windowFeatures);
                          }
                      </script>
                  </ul>
              </div>
              <div class="right col-md-5">
                  <ul class="links">
                      <li><a id="footer-support-link" href="https://support.microsoft.com/en-us/getsupport?wf=0&tenant=ClassicCommercial&oaspworkflow=start_1.0.0.0&locale=en-us&supportregion=en-us&pesid=16064&ccsid=636196895839595242"
                              target="_blank">Support</a></li>
                      <li><a id="footer-privacy-link" href="https://privacy.microsoft.com/en-us/privacystatement"
                              target="_blank">Privacy</a></li>
                      <li><a id="footer-terms-link" href="https://www.microsoft.com/en-us/legal/intellectualproperty/copyright/default.aspx"
                              target="_blank">Terms of Use</a></li>
                      <li><a id="footer-license-link" href="/License">License</a></li>
                  </ul>
                  <div class="copyright">
                      <a id="footer-microsoft-link" class="logo" href="https://www.microsoft.com">
                          <img class="microsoft-logo" src="/assets/images/microsoft-logo.png" height="20" alt="Microsoft homepage"/>
                          <img class="microsoft-logo-inverted" src="/assets/images/microsoft-logo-inverted.png" height="20" alt="Microsoft homepage" />
                      </a>
                      <span>&copy; 2020 <span itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
  <span itemprop="name">Microsoft</span></span>
                      </span>
                  </div>
              </div>
          </div>
      </div>
  </footer>
  <script src="/dist/index.js"></script>

  

  <script type="application/ld+json">
    {
      "@context" : "http://schema.org",
      "@type" : "Product",
      "name" : "Visual Studio Code",
      "logo": "https://code.visualstudio.com/assets/favicon.ico",
      "url" : "https://code.visualstudio.com",
      "potentialAction": {
        "@type": "SearchAction",
        "target": "https://code.visualstudio.com/Search?q={search_term_string}",
        "query-input": "required name=search_term_string"
      },
      "sameAs" : [
      "https://en.wikipedia.org/wiki/Visual_Studio_Code",
      "https://www.facebook.com/visualstudio",
      "https://twitter.com/code",
      "https://blogs.msdn.com/b/vscode"
      ]
    }
  </script>

  <!-- [Begin] JSLL script includes -->
  
  <script type="text/javascript">
    var config = {
      coreData: {
        appId: "vscode"
      }
    };
    if (awa) {
      awa.init(config);
    }
  </script>
  <!-- [End] JSLL script includes --></body>
</html>